Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now
  • How to disable STARTTLS?
    Hi there,

    I'm still stuck at this problem. I've just switched my OST over to apache (was nginx) for another issue, hoping for some side effect. None.
    How can I disable STARTTLS then...?

    Help!
    Filippo

  • How to disable STARTTLS?
    Yes, I'm setting Authentication Required to No, but this way I'm not able to send anything. With Authentication disabled I receive the error:

    Unable to email via SMTP:mail.xxxx.it:587 [info@xxxxx.it] Failed to add recipient: anette@xxxxxx.it [SMTP: Invalid response code received from server (code: 504, response: 5.5.2 : Helo command rejected: need fully-qualified hostname)]

    My ISP confirmed I need Authentication and that I should just disable STARTTLS...

    Thanks,
    Filippo
  • How to disable STARTTLS?
    Hi there,

    I'm running an OSTicket v. 1.10.1 on a Ubuntu 16.04 server, with php 7.0.28.
    I have troubles sending email with SMTP with a single address (the other twelve, from a different domain, work perfectly), googled a couple of days, already substituted PEAR packages (Net_SMTP, Net_Socket) and tried 'tls://', 'ssl://' prefixes/ports in connection settings for the SMTP server. For this server (which I have no control of) of course I need authentication, but connection to 587 with authentication get refused with error:
    authentication failure [SMTP: STARTTLS failed (code: 220, response: 2.0.0 Ready to start TLS)]

    If I telnet from OST server, connection to mail server's port 587 works fine.
    My email service provider doesn't allow port 25, answered he can't deal with OST problems with STARTTLS/self signed certificates and that I should simply disable starttls.
    Is this my best shot? If it is, how do I'd do that?

    Cheers,
    Filippo

  • Postfix Configuration
    Now I installed SASLAUTHD and configured it to use PAM; and now I'm getting this error in mail.log:

    Apr  9 13:56:53 osticket postfix/master[22683]: daemon started -- version 3.1.0, configuration /etc/postfix
    Apr  9 13:56:57 osticket postfix/smtpd[22686]: connect from osticket.mydomain.com[192.168.1.61]
    Apr  9 13:56:57 osticket postfix/smtpd[22686]: warning: SASL authentication failure: unable to canonify user and get auxprops
    Apr  9 13:56:57 osticket postfix/smtpd[22686]: warning: osticket.mydomain.com[192.168.1.61]: SASL DIGEST-MD5 authentication failed: authentication failure
    Apr  9 13:56:57 osticket postfix/smtpd[22686]: disconnect from osticket.mydomain.com[192.168.1.61] ehlo=2 starttls=1 auth=0/1 rset=1 quit=1 commands=5/6
    Apr  9 14:00:17 osticket postfix/anvil[22689]: statistics: max connection rate 1/60s for (smtp:192.168.1.61) at Apr  9 13:56:57
    Apr  9 14:00:17 osticket postfix/anvil[22689]: statistics: max connection count 1 for (smtp:192.168.1.61) at Apr  9 13:56:57
    Apr  9 14:00:17 osticket postfix/anvil[22689]: statistics: max cache size 1 at Apr  9 13:56:57

    So very confused and lost... if I turn off SMTP authentication, I can email and I see through the mail log that I am also receiving email.
    When I'm in CLI I can use the "mail" command to read and check the test emails; which is cool they're getting it. HOWEVER; they're not generating tickets? Why is this?

  • Postfix Configuration
    Does anyone have a good osTicket + Postfix configuration/setup guide? I'm really struggling at the moment.

    We have an exchange server, but its set to relay to the Postfix server running on osTicket.

    I can't seem to get SMTP to authenticate at all.

    Mail.log:
    Apr  9 11:36:08 osticket postfix/smtpd[18220]: NOQUEUE: reject: RCPT from anvexch1.mydomain.com[192.168.1.77]: 454 4.7.1 <rt4ticket@rt4.mydomain.com>: Relay access denied; from=<ticket@nhlearn$
    Apr  9 11:36:08 osticket postfix/smtpd[18220]: disconnect from anvexch1.mydomain.com[192.168.1.77] ehlo=2 starttls=1 mail=1 rcpt=0/1 quit=1 commands=5/6
    Apr  9 11:38:35 osticket postfix/smtpd[18227]: warning: database /etc/aliases.db is older than source file /etc/aliases
    Apr  9 11:38:35 osticket postfix/smtpd[18227]: connect from osticket1.mydomain.com[192.168.1.61]
    Apr  9 11:39:28 osticket postfix/anvil[18222]: statistics: max connection rate 1/60s for (smtp:192.168.1.77) at Apr  9 11:36:08
    Apr  9 11:39:28 osticket postfix/anvil[18222]: statistics: max connection count 1 for (smtp:192.168.1.77) at Apr  9 11:36:08
    Apr  9 11:39:28 osticket postfix/anvil[18222]: statistics: max cache size 1 at Apr  9 11:36:08
    Apr  9 11:40:17 osticket postfix/smtpd[18227]: C324E807A6: client=osticket1.mydomain.com[192.168.1.61]
    Apr  9 11:42:07 osticket postfix/smtpd[18227]: lost connection after RCPT from osticket1.mydomain.com[192.168.1.61]
    Apr  9 11:42:07 osticket postfix/smtpd[18227]: disconnect from osticket1.mydomain.com[192.168.1.61] helo=0/2 ehlo=1/3 mail=1 rcpt=1/2 commands=3/8
    Apr  9 11:42:22 osticket postfix/smtpd[18227]: warning: hostname anvprt01.mydomain.com does not resolve to address 192.168.1.61: Name or service not known
    Apr  9 11:42:22 osticket postfix/smtpd[18227]: connect from unknown[192.168.1.61]
    Apr  9 11:43:20 osticket postfix/smtpd[18227]: 3E842807A6: client=unknown[192.168.1.61]
    Apr  9 11:44:08 osticket postfix/smtpd[18227]: lost connection after DATA (24 bytes) from unknown[192.168.1.61]
    Apr  9 11:44:08 osticket postfix/smtpd[18227]: disconnect from unknown[192.168.1.61] mail=1 rcpt=1/2 data=0/1 commands=2/4
    Apr  9 11:44:08 osticket postfix/cleanup[18297]: 3E842807A6: message-id=<20180409184320.3E842807A6@osticket.mydomain.com>
    Apr  9 11:44:58 osticket postfix/smtpd[18227]: connect from osticket.mydomain.com[192.168.1.61]
    Apr  9 11:44:58 osticket postfix/smtpd[18227]: disconnect from osticket.mydomain.com[192.168.1.61] ehlo=2 starttls=1 rset=1 quit=1 commands=5
    Apr  9 11:45:21 osticket postfix/smtpd[18227]: connect from osticket1.mydomain.com[192.168.1.61]
    Apr  9 11:45:21 osticket postfix/smtpd[18227]: disconnect from osticket1.mydomain.com[192.168.1.61] ehlo=2 starttls=1 rset=1 quit=1 commands=5

    And in the Email settings on OsTicket I get the following error:

    Sending Email via SMTP     
    authentication failure [SMTP: STARTTLS failed (code: 220, response: 2.0.0 SMTP server ready)]

    image
  • Office 365 / Installation issues
    Let me preface this by saying i am aware of the information which i will attach below, regarding microsoft's discontinued support of older security protocols.. I have used the work around suggestion of using a non office 365 server to forward to and have osticket poll from that, obviously this is not the ideal circumstance, and means that we can not reply to emails from customers from our main mail email address.
    My question(s) is/are:
    Is support for these alternative protocols going to be added to osticket in the future?
    If plans to add these features are expected, how quickly is the update planned to be released?
    I'm assuming as the microsoft roll out goes on many users will be coming to the boards with issues as their ticket systems will soon cease to function completely.
    Thank you in advance for your replies.
    Brian

    Users cannot setup any of the email features using an MS Office 365 account, because the system doesn't support TLS/ STARTTLS encryption protocol. The TLS 1.2 protocol has become mandatory (announced by Microsoft in December 2017 with the implementation date on March 1, 2018) as MS is phasing out support for previous protocols TLS1.0, TLS 1.1.

    https://support.microsoft.com/en-us/help/4057306/preparing-for-tls-1-2-in-office-365

    Steps to Reproduce

    Hostname |  outlook.office365.com
    Port Number |  995
    Mail Box Protocol | — Select protocol:   IMAP + SSL ; IMAP ; POP + SSL ; POP

    Expected behavior: Normally, an POP + TLS should also exist
    Actual behavior: There are no 'TLS' options

  • LDAP Authentication and Lookup Plug in, sending unencrypted credentials
    The plugin doesn't seem to work with ldaps on port 636. The checkbox is for the STARTTLS feature, which works on 389 and issues a STARTTLS command after connection. To use straight TLS on port 636 would require changes to the plugin code.   
  • authentication failure [SMTP: STARTTLS failed (code: 220, response: TLS go ahead)]
    Hello there;

    When Completing E-Mail Configuration "Authentication Required" Part Selected Yes . I am receiving an Error Message as below.

    authentication failure [SMTP: STARTTLS failed (code: 220, response: TLS go ahead)]

    All the Information I Entered in the Related Areas is Correct.
    "Authentication Required" Part Selected No. Recording Configuration. But Mail Notification does not come.

    How can I solve this problem?
  • office365 email setup
    Hi,

    Hopefully someone can point me in the right direction I have just setup V1.10 but cannot get sending email via SMTP to work with office365,  I have looked at various disscusions on here regarding this and also had spoken with other users on another forum who sent me a screenshot of there settings and I still cannot get it to work.

    I am running on a synology Nas that has Apache 2.2, and PHP 5.6 installed with MariaDB 10, If I set the hostname to tls://smtp.office365.com or ssl://smtp.office365.com I get an error like this:  Failed to connect to tls://smtp.office365.com:587 [SMTP: Failed to connect socket: Unable to find the socket transport "tls" - did you forget to enable it when you configured PHP? (code: -1, response: )]

    If I set the hostname to just smtp.office365.com I get the following error authentication failure [SMTP: SMTP server does not support authentication (code: 250, response: HE1PR09CA0082.outlook.office365.com Hello [213.246.151.185] SIZE 157286400 PIPELINING DSN ENHANCEDSTATUSCODES STARTTLS 8BITMIME BINARYMIME CHUNKING SMTPUTF8)]

    Any ideas on where I should look 2 days searching on forums and still no further forward with this, thanks for any help in advance.
  • SMTP Gmail - OSTicket
    Good morning.

    I can´t setup smtp gmail in Osticket because I always get an error message. I´ve researched on google and on this forum, but I couldn´t find a solution.
    Can somebody help me, please?

    These are my server information:
    OS: Windows Server 2012 R2 Standard
    osTicket Version: v1.10.1 (9ae093d) —  Up to date
    Web Server Software: Apache/2.4.29 (Win32) OpenSSL/1.0.2l PHP/5.6.32
    MySQL Version: 10.1.28
    PHP Version: 5.6.32

    These are four SMTP settings that I´ve tried with their error messages:
    1-
    Status: Enable
    Hostname: smtp.gmail.com
    Port Number: 587
    Authentication Required: Yes
    Header Spoofing: Allow for this email
    Error: authentication failure [SMTP: STARTTLS failed (code: 220, response: 2.0.0 Ready to start TLS)]

    2-
    Status: Enable
    Hostname: smtp.gmail.com
    Port Number: 465
    Authentication Required: Yes
    Header Spoofing: Allow for this email
    Error: Failed to connect to smtp.gmail.com:465 [SMTP: Invalid response code received from server (code: -1, response: )]

    3-
    Status: Enable
    Hostname: ssl://smtp.gmail.com
    Port Number: 587
    Authentication Required: Yes
    Header Spoofing: Allow for this email
    Error: Failed to connect to ssl://smtp.gmail.com:587 [SMTP: Failed to connect socket: stream_socket_client(): unable to connect to ssl://smtp.gmail.com:587 (Unknown error) (code: -1, response: )]

    4-
    Status: Enable
    Hostname: ssl://smtp.gmail.com
    Port Number: 465
    Authentication Required: Yes
    Header Spoofing: Allow for this email
    Error: Failed to connect to ssl://smtp.gmail.com:465 [SMTP: Failed to connect socket: stream_socket_client(): unable to connect to ssl://smtp.gmail.com:465 (Unknown error) (code: -1, response: )]

    Does somebody has any idea about what I could do?

    Thank you!



  • Problem in Sending Email
    I followed this tutorial to test the connectivity to the Gmail SMTP using the account that is configured to the Osticket. This was also run using the server where the Osticket is installed.  --> https://www.saotn.org/test-smtp-authentication-starttls/

    The results below does not show any error and I am able to receive the test email

    ---
    250 SMTPUTF8
    EHLO xxxxxxxx.com
    250-smtp.gmail.com at your service, [xxx.xxx.xxx.xxx]
    250-SIZE xxxxx
    250-8BITMIME
    250-AUTH LOGIN PLAIN XOAUTH2 PLAIN-CLIENTTOKEN OAUTHBEARER XOAUTH
    250-ENHANCEDSTATUSCODES
    250-PIPELINING
    250-CHUNKING
    250 SMTPUTF8
    AUTH PLAIN xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    235 2.7.0 Accepted
    mail from:<sender@domain.com>
    250 2.1.0 OK xxxxxxxxx - gsmtp
    rcpt to:<recipient@domain.com>
    250 2.1.5 OK xxxxxxxxx - gsmtp
    data
    354  Go ahead xxxxxxxxxxxxxxx - gsmtp
    Test Email
    .
    250 2.0.0 OK xxxxxxxx xxxxxxxxxxxxxxxx - gsmtp
    quit
    221 2.0.0 closing connection xxxxxxxxxxxxxx - gsmtp
    read:errno=0

  • Problem in Sending Email
    Below are the errors I am seeing:

    When Saving the Email Settings:

    Sending Email via SMTP     
    authentication failure [SMTP: STARTTLS failed (code: 220, response: 2.0.0 Ready to start TLS)]


    System Logs:
    Unable to email via php mail function:email@domain.com mail() returned failure


    Diagnostic:

    Error sending email - Please try again!
  • Problem in Sending Email
    Our installation was running with no issue (see details below) until yesterday, I noticed it wont send out email. The system is able to login to IMAP+SSL however in the SMTP it is always getting --> authentication failure [SMTP: STARTTLS failed (code: 220, response: 2.0.0 Ready to start TLS)] when logging in to Google SMTP server smtp.gmail.com on port 587. Temporarily I have set to use aspmx.l.google.com on port 25 however whatever has been sent is not saved in the mailbox account of G Suite. What could be the problem?

    osTicket Version v1.10.1 (9ae093d) —  Up to date
    Web Server Software Microsoft-IIS/7.5
    MySQL Version 5.7.13
    PHP Version 7.0.21
  • Configuring SMTP to work with exchange 2013
    I've looked through the thread http://osticket.com/forum/discussion/3422/failed-to-configure-email-smtp-settings but it relates to an older version and the bits about socket options are already in our version. Changing the 'version_compare(php_version' gives the error
    authentication failure [SMTP: No supported authentication methods (code:250 response: 
    %servername% Hello
    SIZE 26214400
    PIPELINING
    DSN
    ENHANCEDSTATUSCODES
    STARTTLS
    AUTH GSSAPI NTLM
    8BITMIME
    BINARYMIME
    CHUNKING )]
  • Configuring SMTP to work with exchange 2013
    osTicket Version v1.10.1 (9ae093d)
    Web Server Software Apache/2.4.10 (Debian) 
    MySQL Version 5.5.58 
    PHP 5.6.30-0+deb8u1

    We're using a few different mail accounts with our instance and we've got inbound mail working using imap and outbound mail using port 25 and no authentication. This is fine for the emails that are internal mails on mail domains managed by our server. Where it has to relay to other addresses we get the following error
    Mailer Error
    Unable to email via SMTP:%servername%:25 [%accountname%] Failed to add recipient: %externalmail% [SMTP: Invalid response code received from server (code: 550, response: 5.7.1 Unable to relay)]

    If I change one of the mail accounts SMTP settings to port 587 and authentication required, I'm getting 
    Unable to login. Check SMTP settings
    and
    authentication failure [SMTP: STARTTLS failed (code: 220, response:2.0.0. SMTP server ready)]

    If I try telnet in to exchange on 587 from the osticket server I get
    Connected to %servername%
    Escape character is '^] '.
    220 %servername% Microsoft ESMTP MAIL Service ready
    ehlo
    %servername% Hello
    SIZE 26214400
    PIPELINING
    DSN
    ENHANCEDSTATUSCODES
    STARTTLS
    AUTH GSSAPI NTLM
    8BITMIME
    BINARYMIME
    CHUNKING 

    Anyone give me a clue how to get this working?


  • authentication failure [SMTP

    Are you sure that replacing these 2 files 


    will fix this error:

    authentication failure [SMTP: STARTTLS failed (code: 220, response: 2.0.0 SMTP server ready)]


  • Authentication Error
    authentication failure [SMTP: No supported
    authentication methods (code: 250, response: servidor.dominio.com
    Hello [192.168.1.1]
    SIZE
    PIPELINING
    DSN
    ENHANCEDSTATUSCODES
    STARTTLS
    X-ANONYMOUSTLS
    AUTH NTLM
    X-EXPS GSSAPI NTLM
    8BITMIME
    BINARYMIME
    CHUNKING
    XEXCH50
    XRDST
    XSHADOW)]
  • Error de Mailer (code: 530)
    authentication failure [SMTP: No supported
    authentication methods (code: 250, response: servidor.dominio.com
    Hello [192.168.1.1]
    SIZE
    PIPELINING
    DSN
    ENHANCEDSTATUSCODES
    STARTTLS
    X-ANONYMOUSTLS
    AUTH NTLM
    X-EXPS GSSAPI NTLM
    8BITMIME
    BINARYMIME
    CHUNKING
    XEXCH50
    XRDST
    XSHADOW)]
  • Unable to email via SMTP
    From error: Must issue a
    STARTTLS command first
    Have you set the path with ssl://
    Also, I thought Hotmail used live.com?
  • Unable to email via SMTP

    When I try to sending the test mail I get the following problem extensively
    discussed:

     Mailer Error

    Unable to email via SMTP: smtp-mail.outlook.com: 587 [xxxxxxx] Failed to
    set sender:
    xxxxxxxx@hotmail.com [SMTP: Invalid
    response code received from server (code: 530, response: 5.7.0 Must issue a
    STARTTLS command first)]

    Here are the versions I am running:          

    Ubuntu                              16.04 LTS

    OsTicket Version               v1.10 (9012e5ea)

    Web Server Software        Apache/2.4.18 (Ubunu)

    MySQL Version                 5.7.19

    PHP Version            
            7.0.18-0ubuntu0.16.04.1
     

    I have tried everything found in the forums but unsuccessfully. It seems that
    the solution is downgrade to php5.5, for my setting it is not possible, php5.5 it
    not fully supported on ubuntu 16.04 and php5.5 is no longer supported in the
    repository ppa:ondrej/php. 


    I am quite desperate. Please, could you help me?
    Thanks!!!