Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

1.10 Ticket Filter - Add Filter Button does nothing

Note to moderator, I don't see a category for 1.10, so I was not sure where to put this issue. 
osTicket Versionv1.10-rc.2 (231f11e) —  Up to date
Web Server SoftwareApache/2.4.6 (CentOS) PHP/5.4.16
MySQL Version5.5.41
PHP Version5.4.16
I am attempting to create Email filters to direct tickets to the proper Help Topic when they are submitted via email. Problem I am having is that "Add Rule" button on the "Add New Filter" page does nothing. I can fill in all the other information, but clicking on that one button does not allow me to actually do anything. 
This may be related (or maybe not): The "Add New Filter" page does not seem to load properly. When I try to load that page, the progress bar at the top (the orange bar that fills from left to right when loading new pages) stops around 2/3. If I hit refresh, it fully loads. 


  • CentOS... are you running SELinux?  Sounds like you have a problem with AJAX.
  • SELinux is disabled. (I am still not 100% sure what this is, I am new-ish to Linux). The guide I was following suggested turning it off for internal use.

    Interesting you bring up AJAX because there was a message that I could not figure out involving that.
    PHP Settings
    cgi.fix_pathinfo "1" is recommended if AJAX is not working
    date.timezone America/Chicago
    I checked the file, and it is set to 1, so I am not sure what the problem is or how to remedy it.
  • SELinux is basically a firewall software.

    After you changed the php.ini file, did you restart Apache?
  • Apache itself, and then the entire server. Multiple times.
  • As per the article you referenced,
    On line 345, I changed this line:
    var next = <?php echo $maxi; ?>;
    to his line:
    var next = "<?php echo $maxi; ?>";
    I also restarted the Apache server via: 
    #service httpd restart
    Cleared my browsers cache.
    Unfortunately nothing has changed.
  • Alright, so I am not sure why...but I attempted this fix again. This time it worked. 
    The only thing that has changed is that I re-applied some server updates.
    Thank you for the fix. Please close thread.
This discussion has been closed.