Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

cgi.fix_pathinfo and another question

Hi Guys,
I've just upgraded from a heavily modded 1.6ST to 1.9.5 (ecb4f89) and for the most part it went perfectly 
The only thing I can't solve is enabling cgi.fix_pathinfo in php.ini ...it's enabled but osticket says it isn't 

I'm hosting the server with osticket myself on Debian 8 on ESX 5 (runs like greased weasel droppings) 

Osticket Version 1.9.5
Apache 2.4.10 (Debian) 
MySQL 5.5.40
PHP 5.6.4-1

everything is ticked on the information page in Osticket except the cgi.fix_pathinfo with an ominous red triangle and "1" is recommended if AJAX is not working

SystemLinux helpdesk 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt2-1 (2014-12-08) x86_64
Build DateDec 21 2014 19:43:00
Server APIApache 2.0 Handler
Virtual Directory Supportdisabled
Configuration File (php.ini) Path/etc/php5/apache2
Loaded Configuration File/etc/php5/apache2/php.ini
Scan this dir for additional .ini files/etc/php5/apache2/conf.d
Additional .ini files parsed/etc/php5/apache2/conf.d/05-opcache.ini, /etc/php5/apache2/conf.d/10-pdo.ini, /etc/php5/apache2/conf.d/20-apcu.ini, /etc/php5/apache2/conf.d/20-curl.ini, /etc/php5/apache2/conf.d/20-gd.ini, /etc/php5/apache2/conf.d/20-imap.ini, /etc/php5/apache2/conf.d/20-json.ini, /etc/php5/apache2/conf.d/20-ldap.ini, /etc/php5/apache2/conf.d/20-mysql.ini, /etc/php5/apache2/conf.d/20-mysqli.ini, /etc/php5/apache2/conf.d/20-pdo_mysql.ini, /etc/php5/apache2/conf.d/20-readline.ini
So any pointers on how to get that sorted or maybe it's not a problem considering everything seems to work 

The other question is to do with the minimum length of the description you have to put into a ticket when transferring it to another agent
we used to simply put in "yours" or "mine" in 1.6ST but Osticket is demanding a bit more information than a few characters in other words forcing you
to be a bit more verbose......is there a way to reduce the minimum characters required to transfer a ticket ? if so in which bit of the php does it 
reside ?

Thank you in advance 

PS/ I'm completely impressed with the new version and that's saying something coming from somebody who isn't impressed by anything these days ;) 
Well done the team on getting this out there .....it's brilliant 






Comments

  • Did you restart Apache after you changed the config setting?
  • Apache has been restarted more times than I've had coffee today trying to get it fixed .....;)
  • So has the server 
  • It may be enabled in php.ini, but one of the other .ini files in the "include" directory is overriding it. It could be any of those files in the section "Additional .ini files parsed", if they're parsed after the php.ini file.

    I'd create a phpinfo.php file and see what it says (probably the same thing).  Then you will need to read through each of those other .ini files.

    Jack
  • I'll take a look at them now

  • grep "cgi.fix_pathinfo" /etc/php5/apache2/conf.d/*.ini 

    Returned nothing 

  • I've checked each one of those includes and they are just 3 line includes like this 

    ; configuration for php MySQL module
    ; priority=20
    extension=mysql.so
    loading php modules such as apc gd json mysql pdo curl imap ldap and readline.... 

    So I'm stumped as to why it won't load from the main php.ini even though it's set to 1
  • When you run PHP as apache module, it won't read the cgi.fix_pathinfo since it runs as apache module and not via CGI / FastCGI ;)

    Took me also some time to recognize that :D :D :D
  • Yay !!!! thanks for the pointer Chefkeks .....sorted now


    this helped as well ;) 

    Screenshot from 2015-01-30 11:14:10.png
    1173 x 320 - 40K
    Screenshot from 2015-01-30 11:13:28.png
    874 x 562 - 65K
  • Draconis,

    Could you please let me know how you solved it?? I have modified php.ini but warning is still there.

    Regards
Sign In or Register to comment.