Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Reporting Panel [ALPHA RELEASE]

24

Comments

  • list of table in ost_

    hey guys.

    may i know list of table that exist in ost_?
    like ost_ticket, ost_department, ost_staff.

    thanks and appreciate for ur reply.
  • Dazed and Confused

    Problems loading requested supervisor page. (1)
    Possibly access denied, if you believe this is in error please get technical support.


    Has anybody ran into the error above? I've been stuck on this problem for a while now. Can anybody head me in the right direction?

    Thanks!

    jb
  • Activate tab in reporting panel
    cdavis1986;5989 said:
    I figured out part of the problem with the panel. It's passing a DEPT ID of 5 through the query string. My main department is department ID 1, so once I manually changed that it fixed a few problems.
    Deep_CuTz;6033 said:
    Agreed, this fix is easy and takes you straight into the default department.
    This forum has been great for customizing and working through issues. I hope someone might be able to help me with this.

    When selecting the Reporting Panel, it opens to show results under a tab with my department name. The results (not my department) are for department "1", as this is what I have in the monitor file instead of 5 (also not my dept).

    However, it does not show the results for my department unless I click on the actual tab which seems to activate it. How do I get it to show the correct results for the user's department when they open the panel?

    Thanks
  • Great work , but spam problem still there

    I installed the graphics mod and the line distribution
    but I still have the spam problem, I decided to disable the option send emails with sql errors and theres no spam lol, but did someone fix this issue already?
  • Replace "created_by" with "staff_id"
    rufio07;7332 said:
    I installed the graphics mod and the line distribution
    but I still have the spam problem, I decided to disable the option send emails with sql errors and theres no spam lol, but did someone fix this issue already?
    Have you replaced "created_by" with "staff_id" in these 2 files below?
    - \include\staff\rep.header.inc.php
    - \include\staff\rep.users.inc.php

    See what dealin said in hist post at 03-02-2009 03:47 AM above.

    Best regards,
    Masino Sinaga
  • "staff_id" instead of "created_by" in ticket table
    dealin;6587 said:
    2)I changed all references to created_by to staff_id. If the ticket is updated will it change the staff_ID to the user who updated the ticket? if so that is a side effects. I tried to set created_by in the code but was not smart enough. if anyone has the code to do this please post it.

    bill
    Yes, it will!

    I have checked about this in \include\class.ticket.php file, and FOUND this:
        //Close the ticket
    function close(){

    $sql= 'UPDATE '.TICKET_TABLE.' SET status='.db_input('closed').',staff_id=0,isoverdue=0,updated=NOW(),closed=NOW() '.
    ' WHERE ticket_id='.db_input($this->getId());
    return (db_query($sql) && db_affected_rows())?true:false;
    }


    It meant that when a ticket has been closed, then the "staff_id" field will be updated and become "0". I think, this will caused why most of you get no result or always zero in the graph! Duh! :(

    In addition, and in fact, "staff_id" never been inserted to ticket table after you implement my MOD from the link below (it is strongly recommended you apply this MOD):
    http://www.osticket.com/forums/showthread.php?t=2063

    Then, my solution is: I am agree with you that, it is unnecessary to alter ticket table by adding new field named "created_by". I think we should only use this "staff_id" field instead of "created_by" field.

    So that code above should be like this (I removed "staff_id=0" from SQL):
        //Close the ticket
    function close(){

    $sql= 'UPDATE '.TICKET_TABLE.' SET status='.db_input('closed').',isoverdue=0,updated=NOW(),closed=NOW() '.
    ' WHERE ticket_id='.db_input($this->getId());
    return (db_query($sql) && db_affected_rows())?true:false;
    }


    This will cause the "staff_id" in ticket table never been changed forever!

    In addition, if we see in ticket_respon table, the last "staff_id" who has updated the ticket (i.e closed) will be saved in there. So, again, it is unnecessary to update "staff_id" field in ticket table, because we have this "staff_id" saved in ticket_respon table. How's about that? Is it good enough? ;)

    Any other feedback would be truly appreciated. Thanks.

    Best regards,
    Masino Sinaga
  • thanx

    thanks for great work!
  • I noticed that after changing "staff_id" as described above to be kept in ticket table after the ticket is closed that the list of tickets under "My Tickets" now shows tickets that are closed as well as open.

    The solution I implemented for this is entered below. There may be a better way to do it, but I figured I'd offer this in case it helps anyone else:

    include\staff\tickets.inc.php

    Find:

    //Staff's assigned tickets.
    if($staffId && ($staffId==$thisuser->getId())) {
    $results_type='Assigned Tickets';
    $qwhere.=' AND ticket.staff_id='.db_input($staffId);
    Change to:

    //Staff's assigned tickets.
    if($staffId && ($staffId==$thisuser->getId())) {
    $results_type='Assigned Tickets';
    $qwhere.=' AND status=1 AND ticket.staff_id='.db_input($staffId);
    \scp\tickets.php
    Find:

    /*quick stats...*/
    list($assigned)=db_fetch_row(db_query('SELECT count(*) FROM '.TICKET_TABLE.' WHERE staff_id='.db_input($thisuser->getId())));
    Change to:

    /*quick stats...*/
    list($assigned)=db_fetch_row(db_query('SELECT count(*) FROM '.TICKET_TABLE.' WHERE status=1 AND staff_id='.db_input($thisuser->getId())));
  • I dont know if this is just me but I'm having problems downloading the zip files with the reporting mod. Its saying the contents are corrupt. Anyone else having difficulties?

    Cheers,

    Vandrew
  • Vandrew;7572 said:
    I dont know if this is just me but I'm having problems downloading the zip files with the reporting mod. Its saying the contents are corrupt. Anyone else having difficulties?

    Cheers,

    Vandrew
    Sorry I should have said, downloading the zip file is fine, the problem occurs when I try to unzip the files.

    Cheers,

    Vandrew
  • Error unzipping the file

    Hello,
    I'm experiencing also the same error trying to unzip the file that has been linked at the beginning of this thread - can anyone provide me the correct link please? I'm actually using WINZIP trying to extract those files...
    Thanks a lot in advance for your help,
    Marco.

    :confused:
  • Hello, have you solved this?
  • As far as I'm aware this hasn't been resolved. I'm keeping my eye on the thread to see if any update occurs, but no change as yet.
  • sotgiumarco;7626 said:
    Hello, have you solved this?
    I've had some success at last, I downloaded the tar.gz file and extracted it using 7-zip. I isn't an up-to-date version though and does have bugs.

    Try that it has worked for me. I should have thought about doing this first.

    Cheers,

    Vandrew
  • Quick Zip Fix

    Sorry guys, been pre-occupied with school these days...

    I have fixed up the zip file, but no other upgrades yet... hopefully get some time over the semester break to do a lil bit of work on it :)

    Been doing a bit of web engineering in PERL so got a lil more experience up my sleeves now and a better idea of best practise.. So hopefully will be able to make it a lil more user and coder friendly :)

    Once again i hope these aren’t empty hopes and I really do wanna get this panel working well... Will let you know how i go :)

    Keep posting suggestions in here as well, I will be watching intently :)

    ./Jay
  • Staff and Index

    Jay I'm getting some errors when trying to initially setup the files.

    I first get this message

    Warning: require(../JaysReportPanel/scp/staff.inc.php) [function.require]: failed to open stream: No such file or directory in C:\Inetpub\wwwroot\request_test\scp\monitor.php on line 16

    Fatal error: require() [function.require]: Failed opening required '../JaysReportPanel/scp/staff.inc.php' (include_path='.;C:\php5\pear') in C:\Inetpub\wwwroot\request_test\scp\monitor.php on line 16


    But I cannot seem to find those files anywhere in your zip files.

    Also I cannot find the dbConnect files in the jgraph folder. Please let me know how I can easily plug this into my osTicket program.

    Thank you and I'm looking forward to hearing from you.
  • jPGraph Error - Illegal scale

    Hi All,

    Thanks for the mod!

    I have it all working except for this...
    scp/graphs/line.Distribution.php?thumb=0&month=2009-04&dept0=2&f=1

    a plot has an illegal scale...

    I have data for the other 3 graphs but not the line.Distribution graph..

    Hoping it's just data but....

    Thank you
  • line.Distribution graph

    Not getting any data - noting but a 0..
    After debugging sql is throwing up a Resource ID #15 error...
    Any suggestions?
    Thank you all
  • Any Fix Yet?
    TresRans;8163 said:
    Hi All,

    Thanks for the mod!

    I have it all working except for this...
    scp/graphs/line.Distribution.php?thumb=0&month=2009-04&dept0=2&f=1

    a plot has an illegal scale...

    I have data for the other 3 graphs but not the line.Distribution graph..

    Hoping it's just data but....

    Thank you
    I am getting the same result for my first graph.

    Please let me know if you have a fix!!
  • June 30th?

    Hey!

    Great work! I love this MOD!;)

    I installed everything and it works perfect! I can see all graphs and all statistics!

    BUT..where is the June 30th? The graph shows the tickets from Monday 1st till Monday 29th.

    Any ideas?

    Thanks,
    Torben

    Edit: In july its the same. It seems that the graph has the right number of columns, but it starts with "0". that means that one day is missing every month!

    Two possible solutions:
    1. how can I add one column in the graph?
    2. how can I delete the "0-column" in the graph that the graph starts at the 1st of the month?

    Thanks,
    Torben
  • this mod is bug. What i done was finding a chart, put it some security and add it to my ticket.
    Is no a "Panel" but it works. show what i need with colors and graphs.
  • Stupid question

    Hi,
    I've uploaded this and don't see anything different.

    I copied the ~2000 files, but still can only see the "Welcome back Nick, Admin Panel, my Preferences, logoff".

    Any ideas what I screwed up?

    Nick
  • I started to wrok with OS TICKET yesterday and already staff wanted to have stats and reports.
    So I found this absolutly great MOD but some bugs stille resisted :

    - first, I have no CORRELATED GRAPHS, even that I'm admin...
    - the CSV file is quite strange, all is written on a single line,
    - I only can see the graphs with their own URL, the graphs are not visible in OSTICKET,
    - all the volumes in the graphs still at 0.

    Thanks for any help, and again, its clearly a great job !
  • Language Support

    Hi All
    does it support utf-8 encoding???
  • edenfusion;10497 said:
    I started to wrok with OS TICKET yesterday and already staff wanted to have stats and reports.
    So I found this absolutly great MOD but some bugs stille resisted :

    - first, I have no CORRELATED GRAPHS, even that I'm admin...
    - the CSV file is quite strange, all is written on a single line,
    - I only can see the graphs with their own URL, the graphs are not visible in OSTICKET,
    - all the volumes in the graphs still at 0.

    Thanks for any help, and again, its clearly a great job !
    you have to be a department manager to see the graph...:)
  • Can anyone please post a screenshot of this MOD?
  • It's in german, but I think you can see what you want...;)

    Greetings,
    Torben
  • Thanks very much
  • TRBN,
    Could you please share us what you modified to get the great report chart?
    Or you could present your files for us.

    Thanks,
  • Hey s16pt,
    of course I will share it with you, but what do you mean exactly?

    For the colors you have to find in:

    scp/graphs/sBar.ResPerf.php, sBar.VolContact.php and sBar.VolDay.php
    the code:
    // Setup color for gradient fill style 
    $bplot->SetFillGradient('navy','orange',GRAD_RAISED_PANEL);

    and change it to:
    // Setup color for gradient fill style 
    $bplot->SetFillGradient('darkred','orange',GRAD_RAISED_PANEL);


    And in scp/graphs/line.Distribution.php find:

    $p1->SetFillGradient('navy@0.4','orange@0.4');

    and change it to:
    $p1->SetFillGradient('darkred@0.4','orange@0.4');


    I hope that will help you!

    Many greetings,
    Torben
Sign In or Register to comment.