Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Error message on install

Hi :)

I am receiving an error message on the first screen of installation that displays:
Unable to connect to MySQL server. Possibly invalid login info.

The log in info, however, is correct. I have listed

MySQL Table Prefix: databaseprefix_
MySQL Hostname: localhost
MySQL Database: support
MySQL Username: support
MySQL Password: password

The properties are correct on the settings file in the include folder. I am not sure how to get past this screen and get the program to install.

Thanks for any help you can offer :)


  • Is your MySql username really support? Is the MySql password really "password"? I would hope that your password would at least not be "password". My guess is that the credentials that you are supplying are wrong. Did you create the "support" database? This needs to be done before you install osTicket.
  • Sorry - I put in "dummy" information as far as the actual password. It is not really "password" - LOL! Yes - I did create the database prior to set up. All of the information on the setup screen matches what is in the database. The only thing I could think of was that it is looking for something other than "localhost" for the hostname, but I have installed other databases and "localhost" has worked without any issues. I am completely baffled!
  • Is this what you have in your settings.php you mean?

    Here is what I have for mine in include/settings.php:

    #Mysql Login info

    #Table prefix

    The one that seemed odd to me was your table prefix - ost_ is the default.
  • Obvious question, but did you add the user to the database after creating it?

    Can you connect to the database from the command line/other PHP script using those credentials?
  • Thanks guys :) Sorry - I had to step away from this for a day - driving me CRAZY! Yes Kelli - I did add the user to the dbase - good question tho - sometimes it is exactly those kinds of things that mess you up. I am going to try to connect via command line to see if that works.

    Scottro - I will check the settings file itself - good idea.

    Thanks for these suggestions - hopefully one of these will work and I can come back and post that the issue is resolved!
Sign In or Register to comment.