Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Issue upgrading from 1.9.16 to 1.10.1

Hello all,

I have really bad problems with upgrading from 1.9.16  to 1.10.1.
I have running a LAMP-Server (Linux, Apache, MySQL, PHP) with the following version:



osTicket Version     v1.9.16 (f4a172f)
Web Server Software     Apache
MySQL Version     5.5.58
PHP Version     5.6.30-0+deb8u1

I did a snapshot with VMware of my virtual machine (to get back to the running version before upgrade) and followed this instruction, as recommended:
http://osticket.com/wiki/Upgrade_and_Migration

... Copied the upload-folder to the web-folder... overwriting the existing files... restored the old ostconfig.php...

BUT everytime I try to reload my website (in order to run the upgrade-wizard) I get an error! OSticket isn't running anymore (www.webserver.de). Further: If I try to open www.webserver/setup, the system responds, that OSticket is already installed.

I can also provide some logs if needed. (but which?)

Can somebody help me here? I spent a lot of time with troubleshooting.. without any success. I'm confused. :(


Thank you very much for help!
Samuel
Tagged:

Comments

  • restored the ostconfig.php?
    the distribution archive doesn't come with a ostconfig.php.  [It also doesn't come with a ost-config.php file.]

    To upgrade a site you:
    back up the site.
    back up the database.
    download the distribution archive from osticket.com/downloads
    you extract the distribution archive and upload the contents to the location of your osTicket installation.
    You then reload the web page.
    If the upgrade needs to run it will. (it does)

    There are more verbose instructions here:
    http://tmib.net/upgrading-osticket-19x-current-110

    To help more than that we will need to know what your seeing (or errors) that you are getting.
  • Hello,

    I downloaded from https://github.com/osTicket/osTicket/releases/tag/v1.10.1 the "osTicket-v1.10.1.zip".. (8 MB), extracted it, uploaded the content of the "upload"-folder to home-directory of my "working"-osticket-webinstallation, overwriting the exisiting files.... (before I backed up my ost-config.php in the include-directory).

    If I reload my "www.osticket.de"-Page, I got a blank, white page. If I try to open "www.osticket.de/scp", the connection was reset.

    If I open "www.osticket.de/setup", I get the following message:

    osTicket is already installed?

    Configuration file already changed - which could mean
    osTicket is already installed or the config file is corrupted. If you
    are trying to upgrade osTicket, then go to Admin Panel .

    If you believe this is in error, please try replacing
    the config file with a unchanged template copy and try again or get
    technical help.

    Refer to the Installation Guide on the wiki for more information.


    ###############################

    This is my problem (......with the old ost-config.php in the include-directory).
    If I delete the old ost-config.php file, I get the following page displayed:

    Thank You for Choosing osTicket!

    We are delighted you have chosen osTicket for your customer support ticketing system!

    The installer will guide you every step of the way in the
    installation process. You're minutes away from your awesome customer
    support system!

    ....
    => So the NEW installer will run again!! But all I need is an upgrade of my existing installation! :-(
    I also followed the instructions of http://tmib.net/upgrading-osticket-19x-current-110 ....

    Any ideas?

    Thank you. Samuel

  • "If I reload my "www.osticket.de"-Page, I got a blank, white page."

    And what was the corresponding PHP error log message?

    You should not be trying to run setup again.
Sign In or Register to comment.