Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Your lock is expiring soon. -

I've just installed version 1.10 and I'm getting this issue with every ticket...

Your lock is expiring soon.
The lock you hold on this ticket will expire soon. Would you like to renew the lock?


If I try to renew the lock, it just gets stuck there...

If I don't do nothing,  and just try to close the ticket, replying to the user,  I get an error:  

This action requires a lock. Please try again 


What to do ? 

Info:

PHP 5.6
Osticket 1.10 (latest version)
Apache 2.2.15
Mysql 5.5

This was an upgrade from version 1.9

Comments

  • I can think of a number of things that you could do.. but my question is why is this an issue?

    1. increase the lock timer at Admin panel -> Settings -> System -> Collision Avoidance Duration.
    2. set the timer to 0 to disable it.
  • It's an issue, because I can't reply to tickets - always getting an error - This action requires a lock. Please try again... 

    And the spinner keeps spinning every time i say I want to renew the lock...
  • Disabling the lock (0 in the timer) solved the issue ! Thank you
  • Have you tried either of the things I mentioned?
    Do your osticket, serverOS, and db timezones all match?

Sign In or Register to comment.