Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Slow, Error 500 & Mail Issues

Hi Guys,

New to OSTicket and so far I'm loving it. A few minor issues which I am hoping to get some help on...

Firstly I could not get pop3/imap sending via SMTP with authentication whilst using php 5.6, I tried higher version PHP but always got error 500 (Fast-cgi crash), eventually I ended up going to php 5.5.9 - This allowed SMTP / POP to work but not IMAP. Note it was recieving emails on PHP 5.6

The site perfromed superbly fast on PHP 5.6 but now onw 5.5.9 it often hangs, and randomly error 500 shows its face. Now the site sends e-mails but does not pick them up from my exchange server (via POP or POP SSL). There are no errors when saving mailbox settings in emails.php?id=1 page.

Another thing I noticed, was although I have enabled Opache - it shows as not registered on the site, Can you please point me in the correct direction to get the right version? As I suspect this may be the cause of the random slow site access.

The logs haven't been much help in figuring anything out.

My ideal scenario would be to use the latest version of supported PHP whilst having full functionality and fast site access without any hanging.

My Setup Info:

osTicket Version






v1.10 (901e5ea)
Web Server Software Microsoft-IIS/7.5
MySQL Version 5.5.43
PHP Version 5.5.9

Comments

  • I posted enter before I could finish typing and not sure how to edit on this forum as yet.

    Thank you for taking the time to help me out guys and do let me know if you require any further information.
  • edited February 8
    I am having the same problem When I try add a smtp email it crashes the site : http://www.imageupload.co.uk/images/2017/02/08/Error.png

    I am only using this now because for some reason the php email stuff that sends with out smtp, No longer works for some reason it just stopped working. (Yesterday)


    My Server Info:
    Server Information
    osTicket Versionv1.10 (901e5ea) —  Up to date
    Web Server SoftwareApache
    MySQL Version10.0.28
    PHP Version5.6.21
  • I dont see how you could think that this is the same issue when you get an error and Andre does not. Please open your own thread and not hijack someone else's.  Thanks.

    @AndreYPB
    If it ran good under PHP 5.6 why would you downgrade to PHP 5.5?

    Re: exchange server
    Since you can send emails I don't think that its likely that your your issue is a firewall.  
    Could it be that you haven't enabled POP or IMAP on the account that you are trying to collect email with?

    Have you setup Task Scheduler (or Cron) to run cron.php every few minutes?

    Re: opcache
    I dont use this personally... but once you enabled the extension in your php.ini did you restart the webserver software that you are using?
  • Thanks for your reply ntozier, really appreciate it.

    I downgraded PHP because I couldn't get mail to send out from the system on php 5.6. But just to be sure, I'm going to upgrade and test again.

    I will check the exchange account settings for the account again just to be sure - thanks for the reminder.

    I haven't setup TaskScheduler - I thought piping would work? Is this essential?

    Thanks in advance,

    Andre
  • I just tried reverting to PHP 5.6.3 and authentication fails on SMTP with the following error:

    authentication failure [SMTP: STARTTLS failed (code: 220, response: 2.0.0 SMTP server ready)]

    I read somewhere that this was a bug in 5.6 with osticket so I downgraded and authentication worked and I was able to send emails from the system
  • piping should work just fine... but I didn't know that Exchange could pipe.

    But I think that cron.php is becoming more and more necessary and they haven't told us yet. :)
  • @AndreYPB  What did you downgrade to get authentication to work ? 
    What is your php version and Osticket Version?
  • @Parcool

    I downgraded PHP version to 5.5.7, disabled ACPu and OPACHE extensions (for performance related issues).

    I am using the latest version of OSTicket. This is working perfectly for me.

    Regards,

    Andre
Sign In or Register to comment.