Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Office 365 Connection Refused

Server Information
osTicket Versionv1.9.14 (8b927a0) —  Up to date
Web Server SoftwareApache/2.4.18
MySQL Version5.5.45
PHP Version5.4.45
I'm trying to setup the email here and I get the following error regardless if I attempt to connect via POP or IMAP:

Can't connect to,995: Connection refused
The login is correct. (tested via outlook and office 365 mail login)
Things I've tried:- Switching from all forms of connection. POP, POP+SSL, IMAP, IMAP+SSL (Yes I used the correct ports, 993 or 995 . I also tried reversing the ports to see if that could help.)- Changing the email to another email in my office 365 (Still get connection refused)- Setup the email on an 3rd party client (Worked flawlessly. No problems with connection)
I'm out of ideas and yes I searched and couldn't find my exact issue. Seems like others having issue with office 365 mail are having problems at the SMTP end and I haven't even got that far yet.
Any suggestions?
And to verify I'm inputting the following for connections:


  • Cut my last post short.. I'm using the following connection settings:

    Incoming Mail (IMAP) Server:



    Incoming Mail (POP) Server:



    Outgoing Mail (SMTP) Server:



  • This "Can't connect to,995: Connection refused" means your connection is being refused by the server.  Either your user doesn't have the permissions to talk to the server, your server doesn't have permissions to talk to the server, you have a firewall blocking the connection, or your settings are just wrong.
  • edited July 2016
    Does "the server" represent ? Or does it represent the my host where osticket resides? 

    If "the server" represents 
    Then : Either your user doesn't have the permissions to talk to the server 
    (I can login through the office 365 website portal, outlook, and thunderbird) 

    your server doesn't have permissions to talk to the server a.k.a My host, GoDaddy , doesn't have permission to talk to Office 365
    (My mail is through office 365 provided by GoDaddy. If it's provided by GoDaddy and for what I can tell managed by them as I adjust all settings through my GoDaddy login wouldn't it in fact inherit the right to talk to each other? I also contacted GoDaddy previous to making this post and ran them through the setup process of what I'm trying to achieve with osTicket and they said my information , server/port/login credentials are indeed correct and that this was something that had to do with osTicket.)
    You have a firewall blocking the connection
    (Checked with GoDaddy and they do not block connections coming/going from its own servers to )

    or your settings are just wrong.
    (I haven't altered any settings code-wise in osticket . The only settings in which are altered are the selections I chose on the email setup page in osticket. I'll attach a screenshot of this page)

    Any other possible reason for this error?
  • try prefacing SMTP server name with ssl://servername.domain.tld
  • Godaddy blocks Office365 you need to connect to their local SMTP servers.
  • This is my setup .. .you know why it works? Because I host my own system and there are no blocks.
    I am telling you for a fact Godaddy Blocks all SMTP, FTP, SSMTP etc from going out on any web host.
    Go Daddy has local Relay SMTP service to their customers that will forward to office365 with no problem...
  • @ntozier worked perfectly thanks

    @jphilbert I do not have shared hosting and my problem wasn't with smtp . Ntozier suggestion worked and I can send and recieve emails. Thank you for your advice though
  • no prblem.
Sign In or Register to comment.