Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] Authentication required when logging in


I installed osTicket 1.9.x on Plesk, in a windows server.

PHP Version: 5.6.37
MySQL 5.7 Server 5.7.21

However, everytime i try to log into admin panel I get message "Authentication required", my request is code 200 ,regardless whether i put wrong password in or not. Also, when I try to create a new ticket, I get a message saying that a draft is unable to save.

Is there something specific on windows that needs to be configured?

** Update -- I just tried installing the 1.10 version and same thing hapens..


  • When you installed it, did you get any error?  

    Were you ever able to login with whatever admin account you created when you installed osTicket?

    "when I try to create a new ticket, I get a message saying that a draft is unable to save. "
    it could mean permission

    check logs for PHP, MySQL, etc... also if you are able to login to osTicket as admin logs under admin

  • I have enabled errors in php.ini, however there is no php or mysql errors. Running on IIS 10.0 btw. Also when trying to create a ticket, it will get stuck on creating ticket please wait this will take a second, the POST request is all empty and it does not create a ticket at all. I cannot login to the backend with the admin account, or any other accounts. I  tried reinstalling a couple of times and no luck. I though maybe this is because sessions can't be stored or something due to permissions but I have set write/read permissins on the temp dir in C:/Windows/Temp and it still doesn't work.

    I'm completely baffled and out of ideas...
  • Not sure if you tried using different browsers?  And also clearing caches of the browser you are using.
  • Yeah I tried different browsers and clearing cache, none worked. I am getting a status code 422 when trying to log in which according to wiki it's 422 (Unprocessable Entity).
  • You set permission for "I have set write/read permissins on the temp dir in C:/Windows/Temp and it still doesn't work. "

    What about the permission to the location of the osTicket installed?
  • Yes, the permissions are read/write on the os dir
  • When you first installed or re-installed fresh you did not get any errors?
  • No errors at all.
  • I kept installing it through Plesk, and it installed it, however when I
    tried to install it manually, by uploading files my self, and upon
    clicking continue, same thing happens, it just keeps loading and doesnt go to the next stage. Seems like there is something wrong definately but what could that be?
  • 1.9 is end of life so I'm not sure why you would want to install a version that is so old.
    It sounds like there is something going the way the plesk webserver is configured, or some sort of firewall software on the plesk box.
  • Can you try a fresh download of osTicket ver. 1.10.4

  • I did mention before in my post that I have tried the version 1.10 and same thing happens
  • edited September 13

    You are having way too many issues with your setup. Have you tried a completely different server setup to ensure it's not your environment?

    I've never heard of POST requests being blank before...

    Authentication required errors, blank POST requests, no errors anywhere...sounds like a bad environment/setup to me.

  • I think that he has something like Plesk Firewall that is blocking the POST command or something.  But since I dont really know or use Plesk or Plesk Firewall.
  • Okay, sorry.. I was totally stupid yesterday. @ntozier thanks for the hint, WAF was blocking the post requests... All working good now - thanks. 
  • Great glad to hear it!  
    I'mm mark this as resolved and close the thread.  If you have another question, comment, query, etc please open a new thread.

This discussion has been closed.