Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

New Install imap fetching not working.

I made a FRESH install of OsTicket on the newest stable version, on centos 7. My company uses an exchange 2016 server.

I've confirmed, and TRIPLE confirmed the login credentials, and i still get the error :

Can not authenticate to IMAP server: AUTHENTICATE failed.

I've tried both SSL, and non-ssl connections, both with IMAP and POP. Have confirmed the ports are open by telnet. I'm at a loss and the documentation here got me this far. 

Any help is appreciated.

Comments

  • edited August 2
    image
  • Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.

    version of osTicket?
    version of PHP?
    does your Exchange have IMAP/POP enabled? (by default it is no on)
    does your user have IMAP/POP access in Exchange?
    does your web server have permission to talk to Exchange? (transport rules? etc)
  • osticket version : v1.10.4(035fd0a)
    php version : 5.4.16
    Exchange has imap4 enabled and turned on
    user has access to imap/pop per exchange admin portal
    all servers are internal so there is no connectivity issues between them (small organization)
  • "all servers are internal so there is no connectivity issues between them (small organization)"
    So then you disabled SELinux on your CentOS install?
  • correct. I had to so i could finish the install script. I have the firewall completely off on the centos server as well.
  • Can you upgrade to PHP 5.6?
    Are you seeing any errors in your PHP error log?
    Can you check the logs in Exchange to see why the authentication failed?
  • edited August 2
    @travisn

    You have to make sure the Exchange Security Settings allow Plain Authentication. If not you'll never be able to authenticate from osTicket.

    Cheers.
  • @KevinTheJedi

    This would be in the recieve connectors correct? I've enabled basic without the need for TLS on all connectors on our org. Still getting the same error. Hmm.


    @ntozier can you provide steps to update to 5.6 and where id find the logs for php? I can provide the exchange auth logs. 
  • I googled this: CentOS 7 upgrading to php 5.6.9
    https://www.centos.org/forums/viewtopic.php?t=52586


  • Updated to php 5.6 same results.
  • Did you restart the webserver after you upgraded?
    Did you ensure that you are using the new version and not the old?
  • yes and yes. osdesk information tab shows us using php 5.6 now :
    osTicket Versionv1.10.4 (035fd0a) —  Up to date
    Web Server SoftwareApache/2.4.6 (CentOS) PHP/5.6.36
  • Have you tried IMAP+SSL on port 993?

    Have you made sure that the "Microsoft Exchange IMAP4" service is actually running on the Exchange 2016 server?

    I've never had a problem getting osTicket to talk to Exchange (and have used multiple versions of Exchange since 2007 to current)
  • I have tried with 993 and ssl and get the same result.

    I've gone INTO the server itself and saw both IMAP services running. 

    I'm willing to try what we can here. I've always loved OsTicket at my other jobs, just having these problems here and want to use it.
  • edited August 4
    On your screenshot you checked No for authentication required

    It should be Yes I assume

    Also I would try user as domainName\userName
    And up address of server just to check it's not DNS issues
  • @ramrajone

    I have tried with it checked, as well as doing domain\username with the IP of the server to no avail. OS TICKET WHY MuST YOU HATE ME.
  • have you checked your IMAP settings on your mail server?  Is this mail server within the same network or across sites?  you may have routing issue
  • We are a one office shop so its all in the same network on the same subnet. I can telnet from the server osticket is running on to the imap port on the exchange server.
  • are you able to login to an email account you are using via OWA?  Also, try using a local server name.  I had the same issues when I installed it.  It's something is not matching SSL, Port #, Server Name.

    Also, can you make sure the Time Zone/Time is correct on osTicket system and mail server
  • ive tried with about 4 accounts in osticket just to try. none work, however, i can imap on an actual CLIENT on my desktop to the same exchange server on the same network. Timezone/is correct so far from what i can see.
  • Admin panel -> Email -> settings
    You have Email Fetching: enabled?

    You setup cron to run cron.php every couple minutes?
Sign In or Register to comment.