Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

server replacement

I had a server loose a motherboard.  Couldnt get a new board, ended up buying an entire used server of the same model etc.  I moved the raid controller and drives over from the old server to the new.  The only thing I saw was of course the mac address on the replacement hardware is different than the old.  Now my osticket installation will not authenticate using google.  When you click google authentication the screen flashes and I get the authentication required error.  The only thing I can figure is google is denying the connection for the auth, but cant figure that end out.  No errors in the server logs.  All of the other pages running on the server are loading fine.  Including lots of pages using mysql and php, none of these pages are tied into google.  If anyone has any suggestions of where to go I would appreciate a nudge in the right direction.  I did try to dump the mysql database and restore it from a good backup.




  • I've never used the google oauth plugin for osTicket.  

    Have you tried uninstalling and reinstalling the plugin though?
  • If I could get logged into osticket I would try that.  Is there a back door that I can go in, or some way to reset the admin user?
  • Same behavior after resetting password.   Im thinking about starting over from scratch, but have a years worth of support tickets.
  • nvm.  Got in.  Had to remove the backend auth from the user database.  Im in.  Will post what I find out for future people
  • ok.  So if I create a user manually they can login.  However, if a user clicks the google authentication they get a blank screen.  Ive uninstalled the plugin, and reinstalled it.  Checked the settings in the google developer panel.  Im not getting any error messages on the server for php either.   Acts like it isnt redirecting or something.
  • A blank screen usually means that you are encountering a PHP error.  Please check the logs and see if that reveals anything that might help point us in the right direction.
  • Im not seeing any php errors in my httpd error logs and I have logs everything up (E_ALL).  In osticket logs Im seeing this  Auto Cron Mail fetcher cron call.  But that doesnt appear to be an error.  I have errors set to 1 so I will see everything in the config files also.  
    OS ticket version v1.9.3 (bba9ccc)

    Apache/2.2.3 (CentOS) DAV/2 mod_auth_kerb/5.1 mod_auth_pgsql/2.0.3 mod_nss/2.2.3 NSS/ Basic ECC PHP/5.3.28 mod_python/3.2.8 Python/2.4.3 mod_ssl/2.2.3 OpenSSL/0.9.8e-fips-rhel5 mod_perl/2.0.4 Perl/v5.8.8
  • The only change from the old server to the new is the motherboard and since it has built in eth cards the mac address on eth0 has changed.  
  • edited March 5
    Here is the url of the blank page after login:
    [URL removed by forum moderator]

    Could this be a permissions issue? 
  • I removed the url from your post.

    There have been a couple times over the years that people have sworn up and down that there was not PHP errors displayed (or logged).  Most of the times they had logging disabled in the php.ini, but a couple of those times PHP was crashing hard before errors could be logged.  Can you check your php.ini to make sure that logging is actually enabled? 

    The only other thing that I can think of is that 1.9.3 is really old at this point and maybe you just need to upgrade to a more contemporary version.
  • Yes sir.

    Error reporting is on.  I do see error logs for other sites hosted on the box.  

    see below: 

    error_reporting  =  E_ALL

    log_errors = On

    log_errors_max_len = 1024

    With my version of php, what is the max version of osticket that is available?

    thank you

  • PHP 5.3?
    Ummm good question.  I think that would be the 1.8 branch, but it could be some of the earlier 1.9s.  I'm not 100% sure when they change it from 5.3 to 5.4.  I ran 1.9.x and 1.10 on 5.6.
Sign In or Register to comment.