Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] upload error with files larger than 964 kB

Hello support team,


I tested a lot of stuff and I do not know what to do:

My cgi.fix_pathinfo = 1
In my /etc/php/7.0/apache2/php.ini, i changed max size upload
I changed rights (777)on the folder /var/www/ which contains several websites and I changed the owner of the folder with www-data:www-data

Please i need help! thanks


Comments

  • edited February 14
    You have to edit your php.ini and change the following:
    upload_max_filesize = 10M
    post_max_size = 10M
    memory_limit = 12M
    After you do that you would restart Apache.
    Then log into osTicket and go to the Admin panel.
    Settings -> System -> set Agent Maximum File Size:
    Settings -> Tickets -> Ticket Attachment Settings.
    Set Maximum File Size.

    I'm unsure why you would mess with file permissions... unless you installed the Storage::Attachments on the Filesystem plugin.  Which you didn't mention.
  • Hello ntozier,

    First of all thank you for helping me on this problem,I applied recommanded modifications in /etc/php/7.0/apache2/php.ini and i defined the maximum size in settings panel(in attachment).

    Same error under chrome, firefox and internet explorer....
  • Problem resolved !!

    It came from an upstream security filter...thanks for your help and sorry for inconvenience.

  • I'm glad that you managed to get this resolved!  No inconvenience at all.  It's actually what I'm here for, to try to help people with a product that I use and love. :)  Have a great weekend!

    I'll mark this as resolved and close it.  Please feel free to start a new thread if you ahve another question, concern, query, wonder, etc.
This discussion has been closed.