Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

office365 email setup

Hi,

Hopefully someone can point me in the right direction I have just setup V1.10 but cannot get sending email via SMTP to work with office365,  I have looked at various disscusions on here regarding this and also had spoken with other users on another forum who sent me a screenshot of there settings and I still cannot get it to work.

I am running on a synology Nas that has Apache 2.2, and PHP 5.6 installed with MariaDB 10, If I set the hostname to tls://smtp.office365.com or ssl://smtp.office365.com I get an error like this:  Failed to connect to tls://smtp.office365.com:587 [SMTP: Failed to connect socket: Unable to find the socket transport "tls" - did you forget to enable it when you configured PHP? (code: -1, response: )]

If I set the hostname to just smtp.office365.com I get the following error authentication failure [SMTP: SMTP server does not support authentication (code: 250, response: HE1PR09CA0082.outlook.office365.com Hello [213.246.151.185] SIZE 157286400 PIPELINING DSN ENHANCEDSTATUSCODES STARTTLS 8BITMIME BINARYMIME CHUNKING SMTPUTF8)]

Any ideas on where I should look 2 days searching on forums and still no further forward with this, thanks for any help in advance.

Comments

  • This: "SMTP: Failed to connect socket: Unable to find the socket transport "tls" - did you forget to enable it when you configured PHP?"

    Sounds to me like you have not enabled openssl in your PHP configuration file (php.ini).
  • I think you may have hit the nail on the head with openssl, I compleatly missed that.  It is now accepting the configuration without any errors but if I sent a test email I get the following:

    Unable to email via SMTP:smtp.office365.com:587 [helpdesk@] Failed to send data [SMTP: Invalid response code received from server (code: 550, response: 5.7.60 SMTP; Client does not have permissions to send as this sender [AM4PR0201MB2050.eurprd02.prod.outlook.com])]
  • Exchange online is telling you that the user does not have permission to send email as the address that you are trying to use. (Which sounds odd...)
  • its certainly odd, think I will delete the mailbox and resetup from fresh and see if that helps.

    Thanks for the reply
Sign In or Register to comment.