Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Problem in Sending Email

Our installation was running with no issue (see details below) until yesterday, I noticed it wont send out email. The system is able to login to IMAP+SSL however in the SMTP it is always getting --> authentication failure [SMTP: STARTTLS failed (code: 220, response: 2.0.0 Ready to start TLS)] when logging in to Google SMTP server on port 587. Temporarily I have set to use on port 25 however whatever has been sent is not saved in the mailbox account of G Suite. What could be the problem?

osTicket Version v1.10.1 (9ae093d) —  Up to date
Web Server Software Microsoft-IIS/7.5
MySQL Version 5.7.13
PHP Version 7.0.21


  • Did something changed in your environment? Like the php version or so?

    You could try to update the used pear package components of osTicket:
  • There were no changes. Actually its been running for several months already since it was upgraded (v1.10). Suddenly it just wont send any email. I tried your suggestion. It still encrounter the same error. I already upgraded it to (v1.10.1) but the issue still the same.
  • IF it was running fine on 1.10 for several months... then its highly  unlikely that the problem is osTicket.  Something has to have changed some where. PHP version? Perhaps a fire wall?  Perhaps someone changed gmail settings?  perhaps google thought that you were spamming?  perhaps they changed how security works on their product.
  • I have a similar problem, in my case was the SSL certificate of my webserver and the PHP function could not connect with SMTP of Gmail using the SSL 465 port.
  • You can do a Diagnostic of Outgoing Email under Admin>Emails>Diagnostic

    Also, look at the System Logs, it will give more info on the issues
  • Below are the errors I am seeing:

    When Saving the Email Settings:

    Sending Email via SMTP     
    authentication failure [SMTP: STARTTLS failed (code: 220, response: 2.0.0 Ready to start TLS)]

    System Logs:
    Unable to email via php mail mail() returned failure


    Error sending email - Please try again!
  • I am able to test authenticate and send a test email via a Microsoft SMTP server on port 587. But in Gmail I still cannot. I verified in Gmail settings that there are no blocked logins, Allow Less Secure Apps is On. 2 Step Verification is Off.
  • Anyone using G Suite and using their SMTP servers in Osticket? Any issue?
  • I followed this tutorial to test the connectivity to the Gmail SMTP using the account that is configured to the Osticket. This was also run using the server where the Osticket is installed.  -->

    The results below does not show any error and I am able to receive the test email

    250 SMTPUTF8
    EHLO at your service, []
    250-SIZE xxxxx
    250 SMTPUTF8
    AUTH PLAIN xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    235 2.7.0 Accepted
    mail from:<>
    250 2.1.0 OK xxxxxxxxx - gsmtp
    rcpt to:<>
    250 2.1.5 OK xxxxxxxxx - gsmtp
    354  Go ahead xxxxxxxxxxxxxxx - gsmtp
    Test Email
    250 2.0.0 OK xxxxxxxx xxxxxxxxxxxxxxxx - gsmtp
    221 2.0.0 closing connection xxxxxxxxxxxxxx - gsmtp

  • for Gmail I use SSL, TLS give me authentication errors, so, it is more easy to configure. this last week I had problems because certifications but only use a PEM file and was resolved.
  • How you configure a PEM file?
Sign In or Register to comment.