Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Mailer Errors and Warnings

Hello,

we have Osticket 1.10.1 installed and using it successfully in our company. Since the start, in system logs we are having Mailer Error with different descriptions. I am noticing that I (as an administrator) am not receiving all the notification emails I should and also other agents are not receiving all emails they should. There is no pattern - sometimes email notification that is configured is delivered, sometimes it is not. At certain situation, one email notification should be delivered to up to 10 agents - some of them get email notification, some don't.

Also, there is Warning about  Invalid CSRF Token which I don't know meaning of.

I am kindly asking you for comment of these logs, which I am enclosing in the attachment of this discussion and if possible, directions how to correct them.

Comments

  • I have issues with posting an attachments, so I will copy errors text here:

    1.  Unable to email via SMTP :smtp. ...] 
    Failed to set sender: ..... [SMTP: invalid response code received from server (code: -1, response: )]
    2. Unable to email via php mail function:".........." mail() returned failure
    3. Unable to email via SMTP :smtp....] 
    Validation failed for:".........."
    4. Unable to email via php mail function:=?utf-8?Q?
    Ramiz_Be=C4=8Dirhod=C5=BEi=C4=87?= mail() returned failure
    5. Invalid CSRF Token [3709....] on .....upload/scp/login.php

    There are some private information instead of which I put dots "......" in errors.
  • First:
    Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.

    Environment details?
    etc?


    Secondly: 
    there is a lot here...


    "I am noticing that I (as an administrator) am not receiving all the notification emails I should"
    How did you determine this?  What is it you think that your not getting?

    "also other agents are not receiving all emails they should."
    How did you determine this?  What is it you think that they are not getting?

    Seeing the actual messages of the logs would be helpful in determining whats going on.

    "
    Invalid CSRF Token"
    When the login screen is sent to a remote web browser if includes a CSRF token.  If the staff logs in and gets that message then the CSRF token the staff's browser sent back to the server does not match the one sent to them, or it expired.  This can also be caused if the datetime settings of the webserver, mysql server, osticket and PHP do not match, as the token would be expiring before the Agent even gets it.

    "
    I have issues with posting an attachments, so I will copy errors text here:"
    None of that appears to have anything to do with attachments.

    1-4 looks like there is a problem with your mail settings.  Since you haven't provided your mail settings I dont think that anyone can assist you with it.

    I can say that "
    Unable to email via php.ini mail function" probably means that your PHP.ini -> [mail function] doesn't appear to be configured to php mail doesn't work.
  • Hello Ntozier, 

    thank you for your quick response.
    I will try to answer as precise as I can to your questions:

    osTicket Versionv1.10.1 (9ae093d) —  Up to date
    Web Server SoftwareMicrosoft-IIS/8.5
    MySQL Version5.5.45
    PHP Version5.6.31

    "I am noticing that I (as an administrator) am not receiving all the notification emails I should"
    How did you determine this?  What is it you think that your not getting?
    - in Settings->Tickets->Alerts and Notices I set up mail notifications for me (admin) to get notification "New Ticket Alert" and I do not get email about every new ticket. I get for 2-3 successive tickets and then miss next 2-3 tickets and so on.

    "also other agents are not receiving all emails they should."
    How did you determine this?  What is it you think that they are not getting?
    - when new ticket is assigned to agent, alerts and notices are set that way that assigned agent gets email notification about that. That agent sometimes doesn't receive those email notifications on their email address (sometimes they receive)

    In these cases we get Mailer Error in System Logs.

    "Invalid CSRF Token"
    This is something that we get from time to time in System Logs, which then might be the expiration

    "I have issues with posting an attachments, so I will copy errors text here:"
    For some reason uploading attachments here takes forever (3 jpeg documents of total 250 KB), so I cannot attach screen shots of the system logs. That's why I wrote them in my second message. I could message them to you?
  • idaida
    edited December 1
    Email settings:
    - sending emails is enabled through SMTP server with Hostname and Port number written, no authentication required and header spoofing unchecked;

    Not sure if there is something more about email settings that I should provide.

    Thank you and sorry for long post.
    Ida

  • Do you have multiple emails set?
    (and perhaps haven't set up SMTP servers for them?)
  • There are 4 email addresses in Emails list of which:
    - 3 email addresses have sending and fetching emails disabled (no servers are set there at all). They were there from testing period and actually are not in use now.
    - 1 email address has sending emails enabled with mentioned SMTP server set. For that 1 address fetching is disabled, since our Osticket will not receive any tickets through email.

    Only email address from which agents (including administrators) receive emails is that one with sending enabled. 

    Could this have something with our email server provider and its settings?

Sign In or Register to comment.