Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

New page error: No input file specified.

edited October 2017 in Suggestions and Feedback
Hi, I have created a new site page in the "other" category.  My page has been assigned a URL and a link to it has automagically appeared on the homepage under the heading "Other resources", but navigating to the page gives the error "No input file specified.".

Any ideas?


  • Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.
  • Sorry, hopefully these screenshots show what I've done and what's happening:
  • Could this be an .htaccess conflict?  I have this .htaccess file in /pages:

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} (.*/pages)

    RewriteRule ^(.*)$ %1/index.php/$1 [L]


    and this .htaccess in the top level directory to force https:

    # Force https

    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
  • Yes it could be.
    Does your server answer http requests or only https?
  • My server does both.  I need that .htaccess to force https otherwise my osTicket directs to http unless the https is typed explicitly.

    However, I've tried renaming the top level .htaccess to see if this made a difference to the problem and it doesn't.  I have also replaced all the original osTicket files but I still get the same error when I try to view my new page...
  • Hi Nova,

    Did you ever figure this out? I'm running into the same issue.

    (In my case the server will only accept HTTPS connections).
  • P.S.

    osTicket         v1.10.1
    CentOS           7.3.1611 
    Apache 2.4.6-67.el7.centos.6
    nginx 1.11.10-centos7.17102311
    MySQL            5.5.56
    PHP Version 5.4.45

    I've tried switching from Apache to nginx, which produces a 404 error rather than the "No input file" error.

    mod_rewrite is on and working.
  • Bingo! I managed to sort this on my server.

    In my case I have nginx running, but I disabled "Smart static files processing" and now this osTicket function works as expected.

    It doesn't quite make sense to me that this would be the fix, as the Site Pages are certainly not 'static' (perhaps a wiser mind can explain this)... but alas my tech life is never short on unsolved mysteries.

    Hope this helps someone, somewhere, someday.
  • edited March 18
    There was no access to pages that I created in the admin area. To keep things simple I changed the .htaccess file in root/pages with:

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} (.*/pages)

    # RewriteRule ^(.*)$ %1/index.php/$1 [L]
    RewriteRule ^(.*)$$1 [L]


    where # RewriteRule ^(.*)$ %1/index.php/$1 [L] is the original and I added my url. Maybe this is helpful for others with the same problem. And of course, change mydomain to yourdomain!


  • it works i can confirm, just need to edit Apache config rules
Sign In or Register to comment.