Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Supported PHP versions?

Has anyone tried to upgrade the PHP version to 7.0. My service provider is recommending this version, I was wondering if anyone out there has tried this?
Current Versions: 
Osticket v1.9.4, 
mysql 5.1.73 
PHP 5.4.45

Comments

  • If you are really still using osTicket 1.9.4, then you cannot use PHP 7.0 which I believe wasn't support until version 1.10

    If you have to use PHP 7.0, I have seen it suggested that you upgrade to 1.9.15 first, then to 1.10

    There have been several problems reported with PHP 7.0 that have been resolved by backing down to PHP 5.6
  • In short 1.9.4 (ancient) will not work with PHP7.
  • Thanks #blueyeguy & #ntozier for your update. May I ask, as Osticket progresses through versions 1.9.4 (ancient) to 1.9.15 and 1.10 is the code changed to target later versions of PHP?

    Looks like I need to plan an upgrade path for Osticket and PHP.
  • 1.10 is the first version that offers any 7.0.x support.  no versions offer 7.1 support that I know of.
Sign In or Register to comment.