Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

LDAP users access denied

Hello, I recently installed the AD/LDAP Plugin and am having trouble authenticating users. Staff/Admin are able to authenticate via AD/LDAP just fine, but regular users always receive an 'Access Denied' error when trying to sign into the osTicket site.

I checked our AD logs and see the users are being authenticated on the AD server just fine, but somehow osTicket is not getting the positive sign-on notification.






osTicket Version v1.9.12 (19292ad)
Web Server Software Apache
MySQL Version 10.0.28
PHP Version 5.4.45
 Linux                                                                                           3.10.0-327.36.3.el7.x86_64

In my LDAP plugin, I have the AD domain bound successfully as well as the search user authenticated correctly. I set the LDAP Schema to Microsoft AD, and I also have both staff and client authentication boxes ticked.

I need some guidance on what I should be looking for/at as to why clients are showing as able to be authenticated via the AD server logs, but osTicket still refuses to allow access.
Tagged:

Comments

  • You're running 1.9.12 (which is an old version) and you posted this in the section for 1.10.  Moving this to the appropriate section of the forums.

    You might try upgrading to current (or the newest version of the 1.9 branch at least)
  • ntozier,

    I ran the upgrade to get my osTicket to
    v1.10 (901e5ea), and am having the same issue for user authentication.
  • Please see here:

    There is a fix in that thread, and a second fix linked in another comment.
  • I tried both fixes for the ajax.users.php file and the authentication still behaves the same. AD authenticates the user (according to our AD logs), and osTicket gives Access Denied.

    I changed the log level in osTicket to 'Debug', but the access denied does not generate an event in the logs to show a failed login attempt for that user.
  • Is there anything in your PHP error logs?
    Because this works on my site.  I'm running PHP 5.6 though.
  • Only entries I see in the error logs are for unrelated systems/events. I have php logging turned on and reporting set to E_ALL & ~E_DEPRECATED & ~E_STRICT.

  • edited February 21
    Help 
    Please I need help do not authenticate clients with my AD

    osticket v 1.10
    LDAP plugin v 0.6.2
    Centos 7
    php v 5.6.30

  • @Webardo, please do not hijack another thread, create your own. Your issue may be different than Powershd711, so we want it documented properly.

  • ok gracias
  • Help me..

    I have 
    - osticket 1.10
    - Centos 7
    - php v 5.4.16

    i have error 500 on login whit LDAP
  • @Furlani, please do not hijack another thread, create your own. Your issue may be different than the original poster, so we want it documented properly.  That being said you are running php 5.4 and should be running 5.6
Sign In or Register to comment.