Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Ajax not working? cgi.fix_pathinfo

G'day guys,

This may be nothing, reason I say that is because I haven't experienced any adverse effects.
Basically logged in as Admin, navigate to Information page and it shows this:

PHP Settings
cgi.fix_pathinfo "1" is recommended if AJAX is not working
date.timezone Australia/Perth

Here is my discussion with my hosting provider:

I cannot see any issues on our end and the "cgi.fix_pathinfo = 1" workaround should work. I'd recommend to contact the osTicket developers and also let them know that we use Litespeed web server. There might be another workaround involved in order to resolve the error.

Its running on a Cloudlinux server, with cPanel. Latest version of osTicket stable 1.9.8.1. This is what is stored in my php.ini file at the root of my cPanel hosting account. 

post_max_size = 20M
upload_max_filesize = 20M
memory_limit = 256M
max_execution_time = 400
display_error = On
log_errors = On
error_log = "/home/USERNAME/error_log"
always_populate_raw_post_data = -1
cgi.fix_pathinfo = 1
date.timezone = "Australia/Perth"

I can paste parts of my phpinfo if you like. Really I just want to know why it doesn't work? 

Thanks in advance, 
Steve

Comments

  • Hi Steve,

    do you explore any issues beside that cgi.fix_pathinfo? Asking so stupid since I guess it won't make any effect if it is 0 or 1 in your php.ini. Let me explain why:

    "also let them know that we use Litespeed web server"
    First, I guess that Litespeed web server is not supported officially, and second cgi.fix_pathinfo is, as the name includes, a cgi related setting, so when using e.g. PHP as apache module and not cgi, switching that setting won't have any effect since PHP is running as apache module. So maybe you / your host need some different tweak / setting to ensure osTicket ajax works clean with Litespeed web server.

    Cheers,
    Michael
  • As far as I know Litespeed is meant to be a drop in Apache replacement, boasting same configs, etc etc.


    I'm sure that it's something like that, but I don't have any logs to go on why the result is as it is shown. So that is why I'm here :)

    I have zero understanding of how this all works, but generally between Google, my hosting provider and osTicket forum's my issues have been resolved.
  • Not to hijack the thread but I'm seeing this message also, but with apache. The setting is already correct in php.ini. Is it really an error indication or is it just informational?

    Kent
  • To be honest it would appear that this has no effect at least not on my system. The Ajax appears to be working, because I cannot see anything that doesn't function the way it should.

    Anyway websites are not my forte so I'm happy to stand corrected.

    Steve
Sign In or Register to comment.