Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] Links in e-mail templates doesn't work

When recieving e-posts with variables, the links goes to the variable-suffix.
As example:
Variables without links are ok

I have 3 different instanses of OsTicket. One of them is working ok and is version 1.9.3. Two of them are 1.9.4 and these two doesn't work. One is based on IIS and another on Apache. Both on different servers. One of them have language pack and the other one is "out of the box" and have just a minimum of config needed to work.

I have tried to use the  include/class.thread.php from v.1.9.5 (based on this thread)

I'll appretiate any ideas - even if it's not the actual solution. I just need something because i'm stuck and out of ideas :)


  • 1.9.4 is old, please upgrade.

    Also please provide the information for the one that doesn't work.
    You mention having three different installs and vague information on how they are setup, but you dont actually say which one doesn't work, or provide information specific to it.

  • Thank you for your reply :) 

    I don't know what information is relevant regarding the setup/error and this is probably why i'm stuck.

    Instance 1: OK! Running 1.9.3 on a apache server without language pack.
    Instance 2: NOT ok. Running 1.9.4 on a IIS-server with language pack (NO).
    Instance 3: NOT ok. Running 1.9.4 on a apache server without language pack. This instance have no plugins/mods or language pack installed.
  • Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.
  • Thank you for your patience, ntozier! :)

    Short version: Instance 2 is working. Instance 3 is still not, but i think the problem is the template i changed/translated. Now, i cannot enable a new default template so i cannot test this theory for sure.
    Anyway, should'nt the template be the same as long as i use the "insert link"-variable?

    Instance 2: 
    There is no records in the php-log or the osticket log..
    Mail being sent via SMTP (, port 25)
    Web server IIS 8.5
    PHP version 5.5.11
    OS: Windows server 2012 R2

    Instance 3: This one is working. I said in my previous post that it didn't, but i was wrong. No changes made, only me mixing the recieved test-mails together.
    Mail being sent via SMTP (, port 587 with auth. active)
    Web server: Apache 2.4.9 (win64)
    PHP version: 5.5.12
    OS: Windows server 2012 R2

    What i have tried since yesterday:
    Change php-version. Tested with 5.4.24 and 5.3.28
    Disabled plugin "attachments on the filesystem" (the only plugin used)
    Changed my preferred UI back to english

    I just realized that
    one (unedited) of the templates actually is working so i assume the problem lies within the templates. 
    I just made a new template without using any copy but when i try to enable the template, i get a error message saying "Unable to enable selected template set". Yet again, there is no error log in php or osticket.
  • Try going to Admin panel -> Settings -> Email ->
    and change "Default Template Set" and click Save Changes.
  • edited March 2015
    Forgot to respond to this, but the solution from ntoizer is working. Thank you :)

    Change back to default template set and re-make a new template set based on the "default template set"

This discussion has been closed.