Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Trying to upgrade from 1.6RC4 to latest version

I tried to upgrade from 1.6RC4 to 1.91 and got an error after pressing the upgrade button "Critical Error". I read somewhere that I need to get to 1.6ST before I can upgrade to later releases. Is this true?

Any suggestions?

Thanks
«1

Comments

  • Yes that is true. Please upgrade first to the stable version of 1.6, before upgrading further to the latest version. Regarding 1.6 download see this thread here: http://osticket.com/forum/discussion/82705/1-6-0-stable-download#latest
  • Well I tried that, copied the 1.6ST files to the directory, logged into OSTicket, and got this error:

    "The script is version 1.6 ST while the database is version 1.6 RC4"

    What to do now?

    Thanks in advance
  • Just an update, I did try it again and after I uploaded the files I ran /setup/upgrade.php. After that I was able to login and it told me successful upgrade but had very limited options. Logged of and the login page was messed up, the "copyright" was overlapping the login and I was not able to login. restored from backup and I'm back at the beginning.
  • I have no idea what you mean by "but had very limited options".

    Did you clear your web browser cache after upgrading?

    You have to upgrade to 1.6ST prior to being able to upgrade to anything else... and 1.6ST is pretty ancient.
  • Thanks for the reply.

    I will try it again today or tonight and try to post some screen shots for you. The one thing I remember after upgrading and logging in was the "Admin" link was not there. When I logged out and tried to log back in I could not. One thing I did not do is clear the browser cache but I did try two different browsers.

    I'll try it again later today or tonight and see if I can capture some pictures.



    Thanks for the help
  • Well I attempted the update again. Uploaded the 1.6ST files over the top of the existing files. Then ran mydomain/helpdesk/setup/upgarde.php and it returned "Successful" and dhould me the 1.6ST version. I logged in and everything looked good. I went to put the site back on line and it gives me an "internal error" and I can't put the system back on line. There is a screenshot attached.

    Thanks
    OSTicket Offline.JPG
    833 x 292 - 50K

  • image
    OSTicket Offline.JPG
    833 x 292 - 50K
  • You should check your PHP and/or MySQL error logs to see what the actual error being thrown is.
  • Hey ntozier.

    Thanks for all the help. Where would I find those logs? If upgrading doesn't work, what is the migration procedure? I'm going to try the upgrade one more time and see what happens.

    Thanks

  • Well I did the 1.6ST upgrade again and it said it was successful. (see pic) This time I did it with the site online. I logged in and everything was there, could search tickets, create tickets, etc. The only thing I can't to is change setting in the admin system/setting. If I try to make any change I get the "Internal Error" like I got the last time (see pic). Not sure if I should revert back, keep this install and continue upgrading. Where can I find info on this error?

    Thanks
    osticket 1.6st.JPG
    477 x 143 - 24K
    internal error osticket.JPG
    783 x 113 - 24K
  • Hey ntozier. Thanks for all the help. Where would I find those logs? If upgrading doesn't work, what is the migration procedure? I'm going to try the upgrade one more time and see what happens. Thanks
    Depends on your web server. What web server do you use? (apache or IIS or ...)
    You should may take a look at this sticky thread as well regarding the log files of your webserver:
    http://osticket.com/forum/discussion/77766/please-read-before-requesting-assistance#latest

    By migration procedure you mean something like import and export of the tickets currently in your system to a newly set up instance of osTicket?
    Just asking since the migration procedure is to upgrade thru the upgrader. There is no import / export functionality provided by this time, so you will have to either upgrade your existing installation or start over from a scratch (which implies that your current / old tickets are then lost and not transferred to the new installation).
  • We are running Apache on Ubuntu 12.04 LAMP server
  • Then you should look inside /var/log/apache/error_log ;)
  • So after I upgraded to 1.6ST and it showed successful except I couldn't change any settings in the admin panel, (any time I tried got "internal error"), where are those settings kept? In the MySql database? A config file somewhere? Could it be after I upgrade it can't make those changes to the database or I need to change rights on a config file?

    I'll be attempting the upgrade again this week, where are the log files I should check if I run into the same problem? I know about the Apache log you told me. What about PHP or MySql logs and locations?

    Thanks for working with a noobie here :-)
  • The config is in the MySQL database. The connection details to the MySQL database are in /include/ost-config.php (maybe the name is different in 1.6, but should be something with config.php)

    Usually all you have to check is the apache error log (when you run PHP as apache module).
  • edited February 2015
    If you commented out any lines, just be aware that any future upgrades may bring the same problem back.  It would be better to just separate the two email accounts (or just cheat--one address could simply be an alias for the other).

    Jack
  • Thanks Jack,

    That is exactly what I did. I did not comment out those two lines, I changed the Admin email address to something different than the System email address through the Admin Panel>Settings.

    Now on to v1.7ST. After getting to 1.7 should I be able to upgrade to the latest version 1.9 or should I continue to do intermediate upgrades, 1.6ST to 1.7, 1.7 to 1.8, etc.?

    Thanks
  • edited February 2015
    My experience with osTicket began with 1.9.2, so that answer will have to come from someone else.

    Jack
  • Once your st 1.6ST you should be able to upgrade to 1.9.5.1 directly. (note I haven't tried, but that's the intent.)  You simply cannot be running a pre 1.6ST version [1.6RC# is prior to 1.6ST].
  • When trying to update to anything past 1.7 I get the following error:

    Error: Contact system admin.

    I have checked that open tags are set to "on".

    Any other Ideas?

    Thanks,
  • edited February 2015
    We didn't quite get the information requested in
    You gave us a one-liner:
    Apache on Ubuntu 12.04 LAMP server
    We really need more complete information.  That should include your version of php, which may even be the issue here.

    Jack

  • edited February 2015
    Hi Jack,

    Here is the info:

    PHP - 5.3.10
    MySQL - 5.5.41
    Apache - 2.2.22
    Ubuntu - 12.04.1

    Thanks,
  • Ok, so your PHP version is NOT the problem. Have you tried turning on debugging? Below is from the wiki:

    Self-Help Troubleshooting


    If you can not find any solutions to the problem you are having, you can enable the "Show Errors" flags located in /bootstrap.php (or /main.inc.php in older versions):

    #Don't display errors
    ini_set('display_errors',0);
    ini_set('display_startup_errors',0);

    Change this to:

    ini_set('display_errors',1);
    ini_set('display_startup_errors',1);

    Then errors should be displayed either in your web browser or in your server's error.log file.


    Jack
  • Hi Jack,

    Those settings were already enabled in the bootstrap.php and as far as the error.log file located at /var/log/apache2 there is not allot in there:

    [Wed Feb 04 16:53:36 2015] [notice] Graceful restart requested, doing restart
    [Wed Feb 04 16:53:37 2015] [notice] Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.15 with Suhosin-Patch     configured -- resuming normal operations

    That's it

  • There may be useful information in the access logs (rather than the error logs), depending on how Apache is configured.

    The errors should be appearing somewhere, since it's turned on.

    Jack
  • I just don't see anything in any log files pertaining to osticket. For learning purposes, I did do a backup of the osticket database and files once I got to 1.6ST. If I wanted to restore the osticket database to 1.6ST do I need to drop all the tables that are currently in the osticket database so that I have an empty osticket database before I import or is there a command that will overwrite or clear the database during the import?

    Thanks for all the help. This has been a great learning experience for me and I appreciate it!
  • This has gone beyond my ability to help, since I don't have any osTicket experience before 1.9.2.  So, I'm hoping someone else will weigh in.

    Jack
  • You can just drop the database and re-create it.


  • edited February 2015
    Thank you ntozier. That's what I did:

    $mysql -u root -p
    mysql>DROP DATABASE osticket
    mysql>CREATE DATABASE osticket
    mysql>exit

    I then used phpmyadmin to import my backup, deleted everything under the /helpdesk directory, copied my 1.6ST backup files to that directory, and I am now back at 1.6ST  :-)

    At this point I don't see how I'm going to get to 1.9.5 from 1.6ST. If I try to upgrade to anything above 1.7 I seem to get the "Error: Contact system admin." message.

    I think I'm going to go through a clean install of 1.9.5 on my home testbed and see how that goes. If it goes well I'll just do a clean install on our production server. Hate to lose 2 years worth of data but.....???

    Unless you have anything else to try??

    Thanks
Sign In or Register to comment.