Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

How to upload a file which is larger than the maximum size for each attached file(2MB) in osTicket?

In the current Ticket Settings and Options, the maximum value of the Maximum File Size is 2MB. How can I upload a file of size 10MB?

Comments

  • edited October 2014
    I would increase the uploadlimit( upload_max_filesize ) in the php.ini (on my centos server its at /etc/php.ini )
    After you did that you can change the maximum filesize in the "Ticket Settings Options".
    Log in as Admin
    Switch to Admin Panel
    Click on Settings
    Click on Tickets
    Change Maximum Filesize (one of the last points on the page)

    I have tested it with 1.9.3 and 1.9.4-RC5 I guess it would be the same with 1.9.2
  • The only thing that these instructions have left out is that after you make changes to your php.ini a webserver software restart is in order (Apache or IIS).  You would then be able to change the file size in the Admin control panel.
  • I have changed the value of upload_max_filesize to 51M in php.ini and restarted the Apache Server. On the "Ticket Settings and Options" page under Admin Panel, I can now set the Maximum File Size of attachments up to 512MB.

    Howerver, I cannot upload a file with size 336MB and I got the following error messages in the Apache's error.log. It seems that osTicket have set a limit on the file size to 8MB.

    ==============

    [Wed Oct 22 20:37:13.840820 2014] [:error] [pid 308:tid 928] [client 10.13.236.26:53709] PHP Warning:  POST Content-Length of 344634845 bytes exceeds the limit of 8388608 bytes in Unknown on line 0, referer: http://10.13.143.240:88/open.php
    [Wed Oct 22 20:40:48.606445 2014] [:error] [pid 308:tid 920] [client 10.13.236.26:53728] PHP Warning:  POST Content-Length of 344634853 bytes exceeds the limit of 8388608 bytes in Unknown on line 0, referer: http://10.13.143.240:88/open.php
    [Wed Oct 22 20:43:06.725585 2014] [:error] [pid 308:tid 920] [client 10.13.236.26:53737] PHP Warning:  POST Content-Length of 344634845 bytes exceeds the limit of 8388608 bytes in Unknown on line 0, referer: http://10.13.143.240:88/open.php
    [Wed Oct 22 20:51:46.717773 2014] [mpm_winnt:warn] [pid 308:tid 1060] (OS 64)The specified network name is no longer available.  : AH00341: winnt_accept: Asynchronous AcceptEx failed.
    [Wed Oct 22 20:54:08.733398 2014] [:error] [pid 308:tid 920] [client 10.13.236.26:53788] PHP Warning:  POST Content-Length of 344634837 bytes exceeds the limit of 8388608 bytes in Unknown on line 0, referer: http://10.13.143.240:88/open.php
    [Wed Oct 22 20:54:58.295898 2014] [mpm_winnt:warn] [pid 308:tid 1060] (OS 64)The specified network name is no longer available.  : AH00341: winnt_accept: Asynchronous AcceptEx failed.
    [Wed Oct 22 20:55:53.967773 2014] [:error] [pid 308:tid 928] [client 10.13.236.26:53811] PHP Warning:  POST Content-Length of 344634845 bytes exceeds the limit of 8388608 bytes in Unknown on line 0, referer: http://10.13.143.240:88/open.php

    ==============

     

    Any help!

  • Re: "It seems that osTicket have set a limit on the file size to 8MB."

    This statement is simply not true. 

    It's my understanding that two PHP configuration options control the maximum upload size: upload_max_filesize and post_max_size.  You need to make sure that you set them both.

    Files of course take time to upload, and PHP scripts have a maximum execution time.  So you would also need to edit max_input_time and max_execution_time to something like 300 (5 minutes specified in seconds).

    Lastly when PHP is handling an incoming POST it needs to keep some of the incoming data in memory. So you may need to tweak your memory_limit directive.

    Some other things you may want to read:
    http://php.net/manual/en/features.file-upload.php
  • @Eric_So, How did you resolve this issue?
  • Edit PHP.ini.
    save.
    restart webserver software.

  • or just use some cloud service and put a link
Sign In or Register to comment.