Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] LDAP Authentication Fails when the username begins with a number

OS Ticket 1.8 and 1.92

LDAP plugin 0.5 Using the PHAR install.  Staff and client logins are both enabled.

Ubuntu 14.04 LTS 64-bit

When an AD username is made up of all numbers, or begins with a number, login fails with an access denied error. If you add any letter to the beginning of the username in AD and to the staff login in OST, the scp login works normally.

I tested this with the same account.
The first time I used tk1234567890 and the login worked.
I changed the login in AD and OST to 1234567890 and it failed.

We have usernames with all numbers and they are all 10 characters long now unfortunately and they cannot be changed back to the previous format.

I opened a bug on GitHub https://github.com/osTicket/core-plugins/issues/42  But I am hoping someone has seen this and can help me workaround it quickly as my boss wants this online ASAP.  LDAP/AD authentication worked until we changed all of our usernames to all numbers.  Before the change it was a mixture of letters and numbers.

TIA

Comments

This discussion has been closed.