Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] 1.9 Link in customer email not working!

Sorry I thought this was resolved as stated here:
http://osticket.com/forum/discussion/77324/resolved-1-9-link-in-customer-email-not-working#latest

But I got the new download, overwritten my complete Osticket and still got the same problem.

Comments

  • Then you should probably make sure that the new package actually has the fix in it.
    Its located at: https://github.com/osTicket/osTicket-1.8/pull/929


  • Sorry, I don't see any files or packages download on the url you gave me. Only what should be fixed.
    The new package does not have the fix in it.
  • Go to:
    https://github.com/osTicket/osTicket-1.8/pull/929

    click on "Files Changed"
    Click on "View"
    Either high light the files text or click on Click on "Raw" and copy the text.
    Open your /include/class.thread.php
    delete the current contents of the file with copied text.
    Save.
  • Sorry, the patch did not fix the issue.:(

    I clicked on RAW, saved it as class.thread.php and overwritten the existing one.

    The patch is in the file, I checked that. However the problem is still there.

    The view the ticket online link in the customer's email still points to:
    http://www.mydomain.com/support/scp/%{recipient.ticket_link}

    The url bar in the browser still points to:
    http://www.mycompany.com/support/scp/%{recipient.ticket_link}

    Ofcourse still causing a 404 page:
    The requested URL /support/scp/%25%7Brecipient.ticket_link%7D was not found on this server.
  • Sorry... the first mydomain.com is a sample, just like mycompany.com but it's the same domain it's pointing to in the real url.
  • Whats the correct url?
    ie I presume something about http://www.mydomain.com/support/scp/ is wrong.

    Are you using mod_rewrite or mod_redirect or anything similar?
    Whats the settings at: Admin panel -> Settings -> Helpdesk URL?

  • Helpdesk url points to the same domain without /scp so:
    http://www.mydomain.com/support/
    So that should be oke I guess.

    I'm only using a mod_rewrite in my .htaccess on the public_html like this:

    AddHandler application/x-httpd-php .html
    AddType application/x-httpd-php .html
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^mydomain.com [NC]
    RewriteRule ^(.*)$ http://www.mydomain.com/$1 [L,R=301]
    Options -Indexes
    DirectoryIndex pakketten.php

    But imho the %25%7Brecipient.ticket_link%7 is not converted to an existing ticket number before the mail is send out.
    Because the funny thing is, if I reply to that customers ticket, the link which displayed to login is correct. It shows /view.php?t=63 so that one converts correctly.
  • Addition. My rewrite rule should not give any problems I thing.
    Because in /public_html/support I put another .htaccess containing this line:
    DirectoryIndex index.php

  • I agree that its not liktle your rewrite rules... however I thought that you were changing the url to read %{recipient.ticket_link} to mask the actual ticket link from readers here.  What you are actually saying is that emails to clients result in the template variable being improperly added to the url and not translated to the actual ticket link.

    What do you have in your Admin panel -> Emails -> Templates -> your default template.... in say "New Activity Notice" at the bottom?
  • I indeed did not mask en am saying that emails to clients result in the template variable being displayed in the email and not translated to a link, just as you say.

    This is what it says at the bottom (it's a translation) from "New Activity Notice"":

    U krijgt deze email omdat u samenwerkt in ticket #%{ticket.number}.
    Antwoord op deze email om verder te participeren of klik hier voor een compleet overzicht van de berichten in het ticket.

    It's the same as in the default English template which says this:
    You're getting this email because you are a collaborator on ticket #%{ticket.number}. To participate, simply reply to this email or click here for a complete archive of the ticket thread.

  • Odd... if I look at the urls... they all point to /support/scp instead of something else.
  • edited May 2014
    In my installation the link in the template looks like:
    <a href="%{recipient.ticket_link}" style="color: rgb(84, 141, 212);">click here</a>

    note: you can use the <> to see the actual code of the template.

    Please make sure thats correct.
  • Looks the same here if I look at the actual code:

    <em>You're getting this email because you are a collaborator on ticket <a href="%{recipient.ticket_link}" style="color: rgb(84, 141, 212);">#%{ticket.number}</a>. To participate, simply reply to this email or <a href="%{recipient.ticket_link}" style="color: rgb(84, 141, 212);">click here</a> for a complete archive of the ticket thread.</em>

  • You can close the ticket. You brought me on the right track.

    This template was oke. So I started to check the other templates in source mode <> if there could be something wrong there.
    And indeed in the autoresponse ticket there was a difference in the url of the English and the translated version. It might have been something I did myself after installing the translation last week.

    I fixed it and now everything is working oke.

    Thank you very much for your efforts! You can close this and mark it solved.

  • Right on!  I like when we solve thing. :)

    Feel free to start a new thread if you have another question/comment/etc.  Closing thread!
This discussion has been closed.