Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Upgrade to v1.9 RC1 from 1.8.1.2

I am getting this error message: Nothing to do! System already upgraded to v1.8.1.2 with no pending patches to apply.

I am assuming that I have something incorrect?

This is the message I am getting...

Prerequisites:

These items are necessary in order to run the latest version of osTicket.
  • PHP v5.3 or greater - (5.3.28)
  • MySQLi extension for PHP - (module loaded)
  • MySQL v5.0 or greater - (5.5.33)
But v1.8.1.2 works just fine.  I also installed it to a different server and works fine there but I would like to try and upgrade from 1.8... 

Any suggestions?
-sorry for my inexperience/incompetence-

Comments

  • Same. See my screenshot.
    screenshot_0387.png
    965 x 676 - 135K
  • @Giray - can you post the screenshot of the Information page? 
  • Here you go.
    Thanks!!
    screenshot_0388.png
    963 x 595 - 120K
  • Stupid question - Are you sure you downloaded (1.9rc1) and uploaded the files to the right folder, overwriting the existing files? 

  • Yup, yup.
    screenshot_0389.png
    398 x 62 - 9K
  • And the files...
    screenshot_0390.png
    930 x 668 - 209K
  • I guess I'll try a full delete and reinstall...
  • Reinstalled from scratch. Other than the 'db prefix exists' problem that I fixed, we're good to go. However, this means that the upgrade path from 1.8.1.2 to 1.9 RC1 might need some tweaking.
    Bye for now.
  • I performed the upgrade myself with out any problems. 

    The image showing the files makes it look like you did not over right the existing files with the ones from the 1.9rc archive (Look at the file sizes that do not match at all)
  • So, if I am understanding correctly. I need to copy and paste these files into my existing ticket system. allow them to overwrite them and then upgrade?
  • edited May 2014
    Yup.  Backup the files and your database first.

    http://tmib.net/upgrading-osticket-1812-current-19rc
  • I am not sure what is going on here... but I have copied the files and overwritten them. I am still having troubles. I installed it to a different directory and worked just fine.. but I cannot get this to upgrade from 1.8.1.2 is there a way to copy my forms to a different install without losing my forms I have created?
    thanks again!
     image
  • Try deleting the files (save your ost-config.php) then put the files in the folder (and put your ost-config.php back in)?
  • It was easier for me to just copy the ost-config.php from 1.8.1.2 to the 1.9rc1 then upgrade. Thanks again for the help!

    Nate
  • Very welcome. :)

    I'll close this thread, but please feel free to start a new one if you have another question/comment.etc.
This discussion has been closed.