Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Upgrade from v1.7.1 to v1.8.1.2

Hi,
I finished uploading the new v1.8.1.2 files and overwrote my current v1.7.1 install. I then  the ost-config.php with the database settings. However, when I tried to run the upgrade wizard by visiting domain.com/tickets_new/scp/upgrade.php I get the following error:

Parse error: syntax error, unexpected T_STATIC in /html/tickets_new/include/class.plugin.php on line 110

If I also visit domain.com/tickets_new/ i get the same error mesage (see above).

Thanks in advance for any help!


Comments

  • Any help?
  • osTicket 1.8.x+ requires PHP 5.3+  Please upgrade your PHP.
  • Hi! Thanks for the help.
    I am using PHP 5.3. However, I will give it a try upgrading PHP to 5.4

    I'll keep you posted.

  • I am having the same error:
    Parse error: syntax error, unexpected T_STATIC in /html/tickets_temp/include/class.plugin.php on line 110
  • edited March 2014
    I would bet that you have more than one version of PHP installed and are using the wrong one If you make a temp.php file and put it in the base osTicket folder, them edit it and put them browse to it, what version of php does it say?

    Also what's on that line in that file? (From error)

    Did you upgrade your plugins when you upgraded osTicket?
  • edited March 2014
    Thanks ntozier.. I used the phpinfo() instruction and I am noticing the version displayed is 5.2.17 (Even though I manually updated the php version in our hosting provider to 5.4).

    I'll look into this. I'll keep you posted.
  • You rock ntozier! Problem solved.
  • Glad to be able to help. :)  Make sure that you remove the temp.php now that your done with it.  I'll go ahead and close this thread since you're all set.  Please dont hesitate to post again if you have another question/comment/etc.
This discussion has been closed.