Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Staff reply to email alert goes under internal comment

Not sure if I am missing something in the settings or if this is possible. I am running version 1.8.1.2. I have it setup so that my customers can reply to emails coming from osticket and when osticket gets the email it will update the ticket with their response. This works fine and everything but now would like to reply to an email from my staff or admin accounts.

When I reply by email from either staff or admin accounts it will update the ticket with internal notes and the customer cannot see my reply. Can I change this somewhere in the settings to show up as a reply to the customers ticket and also have them receive my response?

--
Jeff

Comments

  • I am having the same exact issue. I have looked over every setting i can find and still can't figure out why it happens.
  • Q: Can I change this somewhere in the settings to show up as a reply to the customers ticket and also have them receive my response?

    A: Nope.  This is how the system works currently.
  • Are there plans to change this behavior?  I like the 1.7.x way better. 

    Or maybe an option to use either way?
  • You can replace two lines in v1.9 to fix this. Open include\class.thread.php and replace
                $vars['note'] = $body;
                return $ticket->postNote($vars, $errors, $poster);
    with
             $vars['message'] = $body;
             return $ticket->postMessage($vars, 'Email');
    But %{poster.name} is not working in email templates in this case. Does anyone know why?
Sign In or Register to comment.