Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

SMTP connection problems specific to 1&1

I am referring to a thread in the 1.7 section of this forum. I tried various versions from 1.7.4 up to the preview 1.8.1 and always have trouble connecting to my SMTP server. I am running osTicket on a hosted Apache Server with php 5.4 (also tried 5.5).

When trying to configure an email address to send via SMTP on my own mailserver I ran into this error message:
Failed to connect to smtp.mydomain.tld:port [SMTP: Failed to connect socket: Connection timed out (code: -1, response: )]
First thing I did was double check credentials of course, but they are fine as I can receive via pop or imap without issues. So I suspected the settings on my mailserver to be somehow in conflict. To verify I tried to use a different email account from 1&1 and get the same error message. Therefore I am pretty sure that there is a problem with how osTicket talks to the SMTP server. There is a note from 1&1 saying that smtp needs to have authentication but NOT Secure Password Authentication (SPA) - is that maybe the issue here?

I veryfied also the correct ports etc. with other email clients the connection is working without issues, so it has to have something to do with osTicket - or did I miss some vital adjustment or setting?

Help is much appreciated, this is the very last thing I simply cannot get to work.



PS
I also tried connecting without SSL (with appropriate ports of course) but the result is the same.

Comments

  • I would recommend talking to 1&1 support.  There is a big difference between you setting up a mail client on your computer and connecting to a mail server than setting one up on the webserver and connecting to the same mail server.

    Alternatively if you would like to try something else first you could write your own mail test script.  You of course do not have to reinvent the wheel and can simply google one.  Here's one.

    http://www.rackspace.com/knowledge_center/article/how-do-i-test-php-smtp-functionality

    If you do that and it works then chances are your right its something osT is doing.  If it does not work however... well you get my point. :)
  • edited January 2014
    Talking to the 1&1 support is an art form I did not yet come round to fully master. I believe it is similar to a journalist interviewing a politician, straight-forward answers are not really their forte.

    Anyways, after being busy with another project I came back to this issue today and did a little more research. First of all thanks for the script, that thing is really helpfull.
    Of course the issue is with the hoster itself or to be more precise with their inability to correctly document their mail servers. Contrary to everything they tell you smtp.1und1.de or smtp.kundenserver.de are not correct if you are accessing smtp directly from a script hosted on their own servers.

    Instead the correct settings are:
    Server: mrvnet.kundenserver.de
    Port: 25
    Authentication: No
  • Thank you for posting your resolution here, hopefully someone else who is having this same problem will see this and it will fix them.  I'm going to close this thread since your resolved, but please feel free to post again should you encounter any further difficulty.
This discussion has been closed.