Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Setting up cronjob


I'd like to set up a cronjob to fetch the emails (email setup was successful). My provider allows to set up cron jobs, so I tried it with /api/cron.php for the domain, which however gives no results. When I access the file manually, I get the message "cron.php only supports local cron calls - use http -> api/tasks/cron"

I also tried to edit the rcron.php and filled in the API key and my domain, then uploaded it to the server and set up a cronjob for this file, but also no result. When I access the file manually, I get the message 

Not Found

The requested URL /osticket/api/tasks/cron was not found on this server.

Note: There is no directory api/tasks/cron in the upload folder that I downloaded.

What am I doing wrong here?


  • is the cron your running located on the same server as your webserver/osTicket install?  If so you use cron.php.  If your cron is run some some place else, then you need to configure the rcron.php file that came with the installation archive and run that instead.
  • edited January 2014
    I do suppose it's the same server. However, nothing happened after I set up the cronjob with cron.php (running every 2 minutes). 

    What can I do to provide you with more information about the issue?
  • Go to:
    Admin panel -> Settings

    Set Default Log Level: to DEBUG

    execute your cron job.

    You should see an entry in Admin panel -> Dash Board -> System Logs
    title: Auto Cron

    With details something like:

    Auto Cron

    Mail fetcher cron call [username]
    Log Date: Wed, Jan 8 2014 3:40pm IP Address: 123.456.789.10

    If you do not then check your PHP error log.
  • For some reason I can't make any changes in Admin/Settings. Once I click Save, everything I changed is set to the default value. The other tabs, like eMail, accept changes. Any ideas what is going on there?

    I checked the access log and for every cron run I get this: - - [08/Jan/2014:17:34:03 +0100] "POST /osticket/api/tasks/cron HTTP/1.1" 404 221 "-" "osTicket API Client v1.7" - - [08/Jan/2014:17:34:02 +0100] "GET /8384cron.php HTTP/1.1" 200 389 "-" "cronBROWSE v0.92" - - [08/Jan/2014:17:34:02 +0100] "GET /api/cron.php HTTP/1.1" 200 68 "-" "cronBROWSE v0.92"

  • "osTicket API Client v1.7"?

    If you are running 1.7.x please upgrade to 1.8.x

    your access log is not your php error log.  Your access log is your webserver logs. 

  • Hi, 
    I am using osticket 1.9 and same its not working for me. Can you please help ?
  • edited February 2016
     Auto Cron

    Mail fetcher cron call [gdshk]

    Log Date: Mon, Feb 22 2016 6:23am IP Address:

     i am getting this.

  • @dtheh Please open your own thread for your issue.  Please also include information regarding your situation.

    Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.
Sign In or Register to comment.