Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Configuration Error

Hello Everyone,

I just installed all the prerequisites and attempt to get the website up and running.

Whenever I go to http://localhost:8080/support/ (or any of it's subfolders) I get this error below.

Any ideas? Am I missing something extremely simple?

OS: Windows 8.1
web.config is default




Server Error in '/' Application.
Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Section or group name 'system.webServer' is already defined. Updates to this may only occur at the configuration level where it is defined.

Source Error:


Line 3:
Line 4:
Line 5:
Line 6:
Line 7:


Source File: C:\inetpub\wwwroot\support\web.config Line: 5


Show Additional Configuration Errors:


The 'type' attribute must be specified on the 'section' tag. (C:\inetpub\wwwroot\support\web.config line 7)

The 'type' attribute must be specified on the 'section' tag. (C:\inetpub\wwwroot\support\web.config line 8)

Comments

  • Somehow this was left out.


    Line 3: Line 4: <configSections> Line 5: <sectionGroup name="system.webServer"> Line 6: <sectionGroup name="rewrite"> Line 7: <section name="rewriteMaps" overrideModeDefault="Allow" />
  • Ok, I figured out that system.webServer is defined in applicationHost.config

    Now I'm trying to figure out how to override it.
  • Also I'm using IIS 8.5, please let me know if it isn't compatible.
  • Thanks for the detailed information. I'll check into the shipped web.config file
  • Hello:

    I have the same error but using IIS 7.5, any ideas how to solve it?
  • jnavarrope have you tried removing the web.config files that ships with osTicket?
  • I had the same problem (also using IIS 7.5). It worked fine for months and then suddenly the same error as mentioned above. When I deleted web.config file, everything worked fine again.

This discussion has been closed.